libprotobuf-c: update to 1.4.0
Remove patch. Upstream fixed it.
Add AUTORELEASE for simplicity.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 40d2b7c43e
)
This commit is contained in:
parent
526b90e5cb
commit
df56b54ba5
2 changed files with 5 additions and 44 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libprotobuf-c
|
||||
PKG_VERSION:=1.3.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.4.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=protobuf-c-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=22956606ef50c60de1fabc13a78fbc50830a0447d780467d3c519f84ad527e78
|
||||
PKG_HASH:=26d98ee9bf18a6eba0d3f855ddec31dbe857667d269bc0b6017335572f85bbcb
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/protobuf-c-$(PKG_VERSION)
|
||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/protobuf-c-$(PKG_VERSION)
|
||||
|
||||
|
@ -53,7 +53,8 @@ CMAKE_HOST_OPTIONS += \
|
|||
-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"
|
||||
|
||||
CMAKE_OPTIONS += \
|
||||
-DBUILD_SHARED_LIBS=ON
|
||||
-DBUILD_SHARED_LIBS=ON \
|
||||
-DBUILD_PROTOC=OFF
|
||||
|
||||
define Package/libprotobuf-c/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
--- a/build-cmake/CMakeLists.txt
|
||||
+++ b/build-cmake/CMakeLists.txt
|
||||
@@ -1,7 +1,10 @@
|
||||
SET(PACKAGE protobuf-c)
|
||||
SET(PACKAGE_NAME protobuf-c)
|
||||
SET(PACKAGE_VERSION 1.3.3)
|
||||
+set(PACKAGE_URL https://github.com/protobuf-c/protobuf-c)
|
||||
+set(PACKAGE_DESCRIPTION "Protocol Buffers implementation in C")
|
||||
|
||||
+include(GNUInstallDirs)
|
||||
|
||||
CMAKE_MINIMUM_REQUIRED(VERSION 2.8 FATAL_ERROR)
|
||||
|
||||
@@ -141,6 +144,9 @@ IF(CMAKE_HOST_UNIX)
|
||||
INSTALL(CODE "EXECUTE_PROCESS (COMMAND ln -sf protoc-gen-c protoc-c WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX}/bin)")
|
||||
ENDIF()
|
||||
|
||||
+CONFIGURE_FILE ("libprotobuf-c.pc.in" "libprotobuf-c.pc" @ONLY)
|
||||
+INSTALL (FILES "../libprotobuf-c.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
|
||||
+
|
||||
INCLUDE(Dart)
|
||||
|
||||
SET(DART_TESTING_TIMEOUT 5)
|
||||
--- /dev/null
|
||||
+++ b/build-cmake/libprotobuf-c.pc.in
|
||||
@@ -0,0 +1,14 @@
|
||||
+prefix=@CMAKE_INSTALL_PREFIX@
|
||||
+exec_prefix=@CMAKE_INSTALL_PREFIX@
|
||||
+bindir=${exec_prefix}/@CMAKE_INSTALL_BINDIR@
|
||||
+libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
|
||||
+includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
|
||||
+
|
||||
+Name: @PACKAGE_NAME@
|
||||
+Version: @PACKAGE_VERSION@
|
||||
+Description: @PACKAGE_DESCRIPTION@
|
||||
+URL: @PACKAGE_URL@
|
||||
+Requires:
|
||||
+Libs: -L${libdir} -lprotobuf-c
|
||||
+Libs.private:
|
||||
+Cflags: -I${includedir}
|
Loading…
Reference in a new issue