Merge pull request #9403 from BKPepe/yt-18.06
[18.06] youtube-dl: update to version 2019.8.2
This commit is contained in:
commit
df3d2312c6
2 changed files with 24 additions and 41 deletions
|
@ -8,45 +8,49 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=youtube-dl
|
||||
PKG_VERSION:=2019.06.21
|
||||
PKG_VERSION:=2019.8.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/ytdl-org/youtube-dl/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=03c6cd1bc112dc8d950cb9d0f05ac90f7111caabcefb1a66483a0fd2319269e0
|
||||
PKG_SOURCE:=youtube_dl-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/y/youtube_dl/
|
||||
PKG_HASH:=73b8528782f507dc506422557c940842e1e514ffaf0b010d82642cb2ceeefdf7
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/youtube_dl-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Adrian Panella <ianchi74@outlook.com>, Josef Schlehofer <pepe.schlehofer@gmail.com>
|
||||
PKG_LICENSE:=Unlicense
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_BUILD_DEPENDS:=python/host zip/host
|
||||
PKG_MAINTAINER:=Adrian Panella <ianchi74@outlook.com>, Josef Schlehofer <pepe.schlehofer@gmail.com>
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../lang/python/python-package.mk
|
||||
|
||||
define Package/youtube-dl
|
||||
SECTION:=multimedia
|
||||
CATEGORY:=Multimedia
|
||||
TITLE:=utility to download videos from YouTube.com
|
||||
URL:=https://yt-dl.org/
|
||||
DEPENDS:=+python-openssl +python-email +python-xml +python-codecs +python-ctypes +ca-certificates
|
||||
TITLE:=Utility to download videos from YouTube.com
|
||||
URL:=https://yt-dl.org
|
||||
DEPENDS:= \
|
||||
+ca-certificates \
|
||||
+python \
|
||||
+python-email \
|
||||
+python-xml \
|
||||
+python-codecs \
|
||||
+python-ctypes \
|
||||
+python-setuptools
|
||||
VARIANT:=python
|
||||
endef
|
||||
|
||||
define Package/youtube-dl/description
|
||||
youtube-dl is a small command-line program to download videos
|
||||
from YouTube.com and a few more sites.
|
||||
from YouTube.com and other video sites.
|
||||
It requires the Python interpreter.
|
||||
endef
|
||||
|
||||
define Package/youtube-dl/install
|
||||
define PyPackage/youtube-dl/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
||||
python -m compileall $(PKG_BUILD_DIR)/youtube_dl/
|
||||
cd $(PKG_BUILD_DIR) && zip --quiet youtube-dl-c.zip youtube_dl/*.pyc youtube_dl/*/*.pyc
|
||||
cd $(PKG_BUILD_DIR) && zip --quiet --junk-paths youtube-dl-c.zip youtube_dl/__main__.pyc
|
||||
echo '#!/usr/bin/env python' > $(PKG_BUILD_DIR)/youtube-dl-c
|
||||
cat $(PKG_BUILD_DIR)/youtube-dl-c.zip >> $(PKG_BUILD_DIR)/youtube-dl-c
|
||||
|
||||
$(INSTALL_BIN) -T $(PKG_BUILD_DIR)/youtube-dl-c $(1)/usr/bin/youtube-dl
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
|
||||
endef
|
||||
|
||||
$(eval $(call PyPackage,youtube-dl))
|
||||
$(eval $(call BuildPackage,youtube-dl))
|
||||
$(eval $(call BuildPackage,youtube-dl-src))
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
diff --git a/Makefile b/Makefile
|
||||
index 4a62f44..fee93e8 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -85,12 +85,12 @@ supportedsites:
|
||||
$(PYTHON) devscripts/make_supportedsites.py docs/supportedsites.md
|
||||
|
||||
README.txt: README.md
|
||||
- pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
|
||||
+# pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
|
||||
|
||||
youtube-dl.1: README.md
|
||||
- $(PYTHON) devscripts/prepare_manpage.py youtube-dl.1.temp.md
|
||||
- pandoc -s -f $(MARKDOWN) -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
- rm -f youtube-dl.1.temp.md
|
||||
+# $(PYTHON) devscripts/prepare_manpage.py youtube-dl.1.temp.md
|
||||
+# pandoc -s -f $(MARKDOWN) -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
+# rm -f youtube-dl.1.temp.md
|
||||
|
||||
youtube-dl.bash-completion: youtube_dl/*.py youtube_dl/*/*.py devscripts/bash-completion.in
|
||||
$(PYTHON) devscripts/bash-completion.py
|
Loading…
Reference in a new issue