Merge pull request #5093 from wigyori/for-15.05-libupnpp

CC: upmpdcli/libupnpp upgrade
This commit is contained in:
Zoltan Herpai 2017-11-12 21:57:56 +01:00 committed by GitHub
commit de8dc83895
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
4 changed files with 50 additions and 21 deletions

View file

@ -1,5 +1,5 @@
#
# Copyright (C) 2014 OpenWrt.org
# Copyright (C) 2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libupnpp
PKG_VERSION:=0.9.0
PKG_VERSION:=0.14.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lesbonscomptes.com/upmpdcli/downloads
PKG_MD5SUM:=ff218bbe2df6cf70b73843d951ef838e
PKG_MD5SUM:=1b10905a365fc6277e1d8ced77278666
PKG_MAINTAINER:=Petko Bordjukov <bordjukov@gmail.com>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
@ -39,14 +39,13 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/libupnpp $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libupnpp-$(PKG_VERSION).so* $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libupnpp.{so,la} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libupnpp.so* $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libupnpp.la $(1)/usr/lib/
endef
define Package/libupnpp/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libupnpp-$(PKG_VERSION).so.* $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libupnpp.so $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libupnpp.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libupnpp))

17
sound/upmpdcli/Config.in Normal file
View file

@ -0,0 +1,17 @@
config PACKAGE_UPMPDCLI_SCCTL
bool "scctl command for configuring SongCast receivers"
default no
depends on PACKAGE_upmpdcli
help
Installs the scctl command. See the following link for more info:
http://www.lesbonscomptes.com/upmpdcli/scmulti.html
config PACKAGE_UPMPDCLI_SC_WEB_INTERFACE
bool "SongCast web server and associated files (depends on python)"
default no
depends on PACKAGE_upmpdcli
select PACKAGE_python
select PACKAGE_UPMPDCLI_SCCTL
help
Installs the SongCast web interface and web server. See the following
link for more info: http://www.lesbonscomptes.com/upmpdcli/scmulti.html

View file

@ -1,5 +1,5 @@
#
# Copyright (C) 2015 OpenWrt.org
# Copyright (C) 2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=upmpdcli
PKG_VERSION:=0.9.0
PKG_RELEASE:=2
PKG_VERSION:=1.1.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lesbonscomptes.com/upmpdcli/downloads
PKG_MD5SUM:=0e7b86037f19ea3a08067409af6f6902
PKG_MD5SUM:=de9f232d6d5f746ec81ec239e11bdda4
PKG_MAINTAINER:=Petko Bordjukov <bordjukov@gmail.com>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
@ -29,12 +29,17 @@ define Package/upmpdcli
DEPENDS+= +libupnpp +libmpdclient
TITLE:=A UPnP front-end to MPD, the Music Player Daemon
USERID:=upmpdcli=89:upmpdcli=89
MENU:=1
endef
define Package/upmpdcli/description
upmpdcli implements an UPnP Media Renderer, using MPD to perform the real work.
endef
define Package/upmpdcli/config
source "$(SOURCE)/Config.in"
endef
define Package/upmpdcli/install
$(INSTALL_DIR) $(1)/etc
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/upmpdcli.conf $(1)/etc/
@ -42,8 +47,14 @@ define Package/upmpdcli/install
$(INSTALL_CONF) ./files/upmpdcli.config $(1)/etc/config/upmpdcli
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/upmpdcli $(1)/usr/bin/
ifeq ($(CONFIG_PACKAGE_UPMPDCLI_SCCTL),y)
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/scctl $(1)/usr/bin/
endif
$(INSTALL_DIR) $(1)/usr/share/upmpdcli
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/upmpdcli/* $(1)/usr/share/upmpdcli/
ifneq ($(CONFIG_PACKAGE_UPMPDCLI_SC_WEB_INTERFACE),y)
$(RM) -rf $(PKG_INSTALL_DIR)/usr/share/upmpdcli/web
endif
$(CP) -r $(PKG_INSTALL_DIR)/usr/share/upmpdcli $(1)/usr/share/
$(INSTALL_DATA) ./files/upmpdcli.png $(1)/usr/share/upmpdcli/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/upmpdcli.init $(1)/etc/init.d/upmpdcli

View file

@ -1,9 +1,11 @@
--- a/src/upmpdcli.conf
+++ b/src/upmpdcli.conf
@@ -53,3 +53,6 @@ ohmetapersist = 1
# Path to the sc2mpd if it is not in /usr/bin and the location is not in
# the PATH for the init scripts.
#sc2mpd = /usr/bin/sc2mpd
+
+# Icon for MPD UPnP interface
+iconpath = /usr/share/upmpdcli/upmpdcli.png
--- a/src/upmpdcli.conf-dist
+++ b/src/upmpdcli.conf-dist
@@ -24,7 +24,7 @@
# You can set a path to an icon here. The icon will be displayed by a control
# point. The icon will only be read once, when upmpdcli starts up.
-# iconpath = /usr/share/upmpdcli/icon.png
+iconpath = /usr/share/upmpdcli/icon.png
# You can set a path to an html file here, to replace the default
# presentation page. The page will only be read once, when upmpdcli starts