miniupnpc: Update to 2.1
Switched URL to official HTTPS variant. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
3b6e346a4c
commit
de26b21879
3 changed files with 7 additions and 7 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=miniupnpc
|
PKG_NAME:=miniupnpc
|
||||||
PKG_VERSION:=2.0.20170509
|
PKG_VERSION:=2.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://miniupnp.free.fr/files
|
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_HASH:=d3c368627f5cdfb66d3ebd64ca39ba54d6ff14a61966dbecb8dd296b7039f16a
|
PKG_HASH:=e19fb5e01ea5a707e2a8cb96f537fbd9f3a913d53d804a3265e3aeab3d2064c6
|
||||||
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/miniupnpc/Default
|
define Package/miniupnpc/Default
|
||||||
TITLE:=Lightweight UPnP
|
TITLE:=Lightweight UPnP
|
||||||
URL:=http://miniupnp.tuxfamily.org/
|
URL:=https://miniupnp.tuxfamily.org
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/miniupnpc
|
define Package/miniupnpc
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -187,8 +187,8 @@ installpythonmodule3: pythonmodule3
|
@@ -186,8 +186,8 @@ installpythonmodule3: pythonmodule3
|
||||||
python3 setup.py install
|
MAKE=$(MAKE) python3 setup.py install
|
||||||
|
|
||||||
validateminixml: minixmlvalid
|
validateminixml: minixmlvalid
|
||||||
- @echo "minixml validation test"
|
- @echo "minixml validation test"
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/upnpcommands.c
|
--- a/upnpcommands.c
|
||||||
+++ b/upnpcommands.c
|
+++ b/upnpcommands.c
|
||||||
@@ -370,7 +370,7 @@ UPNP_AddPortMapping(const char * control
|
@@ -371,7 +371,7 @@ UPNP_AddPortMapping(const char * control
|
||||||
AddPortMappingArgs[5].elt = "NewEnabled";
|
AddPortMappingArgs[5].elt = "NewEnabled";
|
||||||
AddPortMappingArgs[5].val = "1";
|
AddPortMappingArgs[5].val = "1";
|
||||||
AddPortMappingArgs[6].elt = "NewPortMappingDescription";
|
AddPortMappingArgs[6].elt = "NewPortMappingDescription";
|
||||||
|
|
Loading…
Reference in a new issue