bonnie++: Remove wrongly added patch during cherry-pick
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
c3f6660b8b
commit
ddc48c3d5a
1 changed files with 0 additions and 38 deletions
|
@ -1,38 +0,0 @@
|
|||
Index: bonnie++-1.97.1/configure
|
||||
===================================================================
|
||||
--- bonnie++-1.97.1.orig/configure
|
||||
+++ bonnie++-1.97.1/configure
|
||||
@@ -3955,9 +3955,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
|
||||
if test "$cross_compiling" = yes; then :
|
||||
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "cannot run test program while cross compiling
|
||||
-See \`config.log' for more details" "$LINENO" 5 ; }
|
||||
+$as_echo "$as_me: error: in \`$ac_pwd':" >&2;} }
|
||||
else
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
Index: bonnie++-1.97.1/Makefile
|
||||
===================================================================
|
||||
--- bonnie++-1.97.1.orig/Makefile
|
||||
+++ bonnie++-1.97.1/Makefile
|
||||
@@ -1,5 +1,7 @@
|
||||
EXES=bonnie++ zcav getc_putc getc_putc_helper
|
||||
EXE=bon_csv2html generate_randfile
|
||||
+TARGET_CXX=g++
|
||||
+TARGET_LINK=g++
|
||||
|
||||
all: $(EXE) $(EXES)
|
||||
|
||||
@@ -10,8 +12,8 @@ eprefix=${prefix}
|
||||
#MORE_WARNINGS=-Weffc++
|
||||
WFLAGS=-Wall -W -Wshadow -Wpointer-arith -Wwrite-strings -pedantic -ffor-scope -Wcast-align -Wsign-compare -Wpointer-arith -Wwrite-strings -Wformat-security -Wswitch-enum -Winit-self $(MORE_WARNINGS)
|
||||
CFLAGS=-O2 -DNDEBUG $(WFLAGS) $(MORECFLAGS)
|
||||
-CXX=g++ $(CFLAGS)
|
||||
-LINK=g++
|
||||
+CXX=$(TARGET_CXX) $(CFLAGS)
|
||||
+LINK=$(TARGET_LINK)
|
||||
THREAD_LFLAGS=-lpthread
|
||||
|
||||
INSTALL=/usr/bin/install -c
|
Loading…
Reference in a new issue