python: Update to 2.7.18, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
baacda1b4a
commit
dd5896c7c4
4 changed files with 6 additions and 6 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PYTHON_VERSION:=2.7
|
||||
PYTHON_VERSION_MICRO:=17
|
||||
PYTHON_VERSION_MICRO:=18
|
||||
|
||||
PYTHON_SETUPTOOLS_PKG_RELEASE:=1
|
||||
PYTHON_PIP_PKG_RELEASE:=1
|
||||
|
|
|
@ -16,7 +16,7 @@ PKG_RELEASE:=1
|
|||
|
||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
||||
PKG_HASH:=4d43f033cdbd0aa7b7023c81b0e986fd11e653b5248dac9144d508f11812ba41
|
||||
PKG_HASH:=b62c0e7937551d0cc02b8fd5cb0f544f9405bafc9a54d3808ed4594812edef43
|
||||
|
||||
PKG_LICENSE:=PSF
|
||||
PKG_LICENSE_FILES:=LICENSE Modules/_ctypes/libffi_msvc/LICENSE Modules/_ctypes/darwin/LICENSE Modules/_ctypes/libffi/LICENSE Modules/_ctypes/libffi_osx/LICENSE Tools/pybench/LICENSE
|
||||
|
|
|
@ -17,4 +17,4 @@ Subject: [PATCH] enable zlib
|
|||
+zlib zlibmodule.c -lz
|
||||
|
||||
# Interface to the Expat XML parser
|
||||
#
|
||||
# More information on Expat can be found at www.libexpat.org.
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -7077,7 +7077,7 @@ sys/param.h sys/poll.h sys/random.h sys/
|
||||
@@ -7084,7 +7084,7 @@ sys/param.h sys/poll.h sys/random.h sys/
|
||||
sys/termio.h sys/time.h \
|
||||
sys/times.h sys/types.h sys/un.h sys/utsname.h sys/wait.h pty.h libutil.h \
|
||||
sys/resource.h netpacket/packet.h sysexits.h bluetooth.h \
|
||||
|
@ -9,7 +9,7 @@
|
|||
do :
|
||||
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
||||
ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
|
||||
@@ -7299,6 +7299,24 @@ fi
|
||||
@@ -7306,6 +7306,24 @@ fi
|
||||
fi
|
||||
|
||||
|
||||
|
@ -36,7 +36,7 @@
|
|||
do :
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1732,10 +1732,17 @@ sys/param.h sys/poll.h sys/random.h sys/
|
||||
@@ -1739,10 +1739,17 @@ sys/param.h sys/poll.h sys/random.h sys/
|
||||
sys/termio.h sys/time.h \
|
||||
sys/times.h sys/types.h sys/un.h sys/utsname.h sys/wait.h pty.h libutil.h \
|
||||
sys/resource.h netpacket/packet.h sysexits.h bluetooth.h \
|
||||
|
|
Loading…
Reference in a new issue