memcached: bump to version 1.4.26
Signed-off-by: heil <heil@terminal-consulting.de>
This commit is contained in:
parent
1338510979
commit
dd4b385702
3 changed files with 8 additions and 53 deletions
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=memcached
|
||||
PKG_VERSION:=1.4.24
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.4.26
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://memcached.org/files
|
||||
PKG_MD5SUM:=4d6e8c90e2068580526c7579dd7f37f6
|
||||
PKG_MD5SUM:=59b7bbfbc9cde5731bf4446e1e37b440
|
||||
PKG_INSTALL:=1
|
||||
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
|
||||
PKG_LICENSE:=permissive free software license
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
--- memcached-1.4.15.orig/assoc.c
|
||||
+++ memcached-1.4.15/assoc.c
|
||||
@@ -14,8 +14,8 @@
|
||||
#include "memcached.h"
|
||||
#include <sys/stat.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/signal.h>
|
||||
#include <sys/resource.h>
|
||||
+#include <signal.h>
|
||||
#include <fcntl.h>
|
||||
#include <netinet/in.h>
|
||||
#include <errno.h>
|
||||
--- memcached-1.4.15.orig/items.c
|
||||
+++ memcached-1.4.15/items.c
|
||||
@@ -2,13 +2,13 @@
|
||||
#include "memcached.h"
|
||||
#include <sys/stat.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/signal.h>
|
||||
#include <sys/resource.h>
|
||||
#include <fcntl.h>
|
||||
#include <netinet/in.h>
|
||||
#include <errno.h>
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
+#include <signal.h>
|
||||
#include <string.h>
|
||||
#include <time.h>
|
||||
#include <assert.h>
|
||||
--- memcached-1.4.15.orig/slabs.c
|
||||
+++ memcached-1.4.15/slabs.c
|
||||
@@ -10,7 +10,6 @@
|
||||
#include "memcached.h"
|
||||
#include <sys/stat.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/signal.h>
|
||||
#include <sys/resource.h>
|
||||
#include <fcntl.h>
|
||||
#include <netinet/in.h>
|
||||
@@ -18,6 +17,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
+#include <signal.h>
|
||||
#include <assert.h>
|
||||
#include <pthread.h>
|
||||
|
|
@ -1,5 +1,7 @@
|
|||
--- a/memcached.c
|
||||
+++ b/memcached.c
|
||||
Index: memcached-1.4.26/memcached.c
|
||||
===================================================================
|
||||
--- memcached-1.4.26.orig/memcached.c
|
||||
+++ memcached-1.4.26/memcached.c
|
||||
@@ -13,6 +13,10 @@
|
||||
* Anatoly Vorobey <mellon@pobox.com>
|
||||
* Brad Fitzpatrick <brad@danga.com>
|
||||
|
@ -11,7 +13,7 @@
|
|||
#include "memcached.h"
|
||||
#include <sys/stat.h>
|
||||
#include <sys/socket.h>
|
||||
@@ -29,9 +33,6 @@
|
||||
@@ -30,9 +34,6 @@
|
||||
#define _P1003_1B_VISIBLE
|
||||
#endif
|
||||
/* need this to get IOV_MAX on some platforms. */
|
||||
|
|
Loading…
Reference in a new issue