diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index 023fdc22f..e6068f7ca 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
 PKG_VERSION:=4.0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
diff --git a/net/adblock/files/adblock.init b/net/adblock/files/adblock.init
index 64dbd7684..c75ddee67 100755
--- a/net/adblock/files/adblock.init
+++ b/net/adblock/files/adblock.init
@@ -8,14 +8,13 @@
 START=30
 USE_PROCD=1
 
-EXTRA_COMMANDS="suspend resume query report list timer status_service version"
-EXTRA_HELP="	suspend	Suspend adblock processing
-	resume	Resume adblock processing
-	query	<domain> Query active blocklists and backups for a specific domain
-	report	[<search>] Print DNS statistics with an optional search parameter
-	list	[[<add>|<remove>] [source(s)]] List available adblock sources or add/remove them from config
-	timer	<action> <hour> [<minute>] [<weekday>] Set a cron based update interval
-	version	print version information"
+extra_command "suspend" "Suspend adblock processing"
+extra_command "resume" "Resume adblock processing"
+extra_command "query" "<domain> Query active blocklists and backups for a specific domain"
+extra_command "report" "[<search>] Print DNS statistics with an optional search parameter"
+extra_command "list" "[[<add>|<remove>] [source(s)]] List available adblock sources or add/remove them from config"
+extra_command "timer" "<action> <hour> [<minute>] [<weekday>] Set a cron based update interval"
+extra_command "version" "Print version information"
 
 adb_init="/etc/init.d/adblock"
 adb_script="/usr/bin/adblock.sh"
diff --git a/net/adblock/test.sh b/net/adblock/test.sh
deleted file mode 100755
index 607de9758..000000000
--- a/net/adblock/test.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-/etc/init.d/"${1}" version 2>/dev/null | grep "${2}"