glib2: update to 2.56.0
Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
parent
412c262e76
commit
dc813c8253
3 changed files with 4 additions and 28 deletions
|
@ -8,13 +8,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=glib2
|
PKG_NAME:=glib2
|
||||||
PKG_VERSION:=2.55.1
|
PKG_VERSION:=2.56.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
|
||||||
PKG_SOURCE_URL:=@GNOME/glib/2.55
|
PKG_SOURCE_URL:=@GNOME/glib/2.56
|
||||||
PKG_HASH:=0cbb3d31c9d181bbcc97cba3d9dbe3250f75e2da25e5f7c8bf5a993fe54baf6a
|
PKG_HASH:=ecef6e17e97b8d9150d0e8a4b3edee1ac37331213b8a2a87a083deea408a0fc7
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
HOST_BUILD_PARALLEL:=1
|
HOST_BUILD_PARALLEL:=1
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/gtk-doc.make
|
--- a/gtk-doc.make
|
||||||
+++ b/gtk-doc.make
|
+++ b/gtk-doc.make
|
||||||
@@ -277,7 +277,7 @@ uninstall-local:
|
@@ -298,7 +298,7 @@ uninstall-local:
|
||||||
#
|
#
|
||||||
# Require gtk-doc when making dist
|
# Require gtk-doc when making dist
|
||||||
#
|
#
|
||||||
|
|
|
@ -1,24 +0,0 @@
|
||||||
From 0817af40e8c74c721c30f6ef482b1f53d12044c7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: coypu <coypu@sdf.org>
|
|
||||||
Date: Mon, 8 Feb 2016 00:06:06 +0200
|
|
||||||
Subject: gdate: Suppress string format literal warning
|
|
||||||
|
|
||||||
Newer versions of GCC emit an error here, but we know it's safe.
|
|
||||||
https://bugzilla.gnome.org/761550
|
|
||||||
---
|
|
||||||
glib/gdate.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
--- a/glib/gdate.c
|
|
||||||
+++ b/glib/gdate.c
|
|
||||||
@@ -2497,7 +2497,10 @@ g_date_strftime (gchar *s,
|
|
||||||
* recognize whether strftime actually failed or just returned "".
|
|
||||||
*/
|
|
||||||
tmpbuf[0] = '\1';
|
|
||||||
+ #pragma GCC diagnostic push
|
|
||||||
+ #pragma GCC diagnostic ignored "-Wformat-nonliteral"
|
|
||||||
tmplen = strftime (tmpbuf, tmpbufsize, locale_format, &tm);
|
|
||||||
+ #pragma GCC diagnostic pop
|
|
||||||
|
|
||||||
if (tmplen == 0 && tmpbuf[0] != '\0')
|
|
||||||
{
|
|
Loading…
Reference in a new issue