diff --git a/utils/lcd4linux/Makefile b/utils/lcd4linux/Makefile
index b353bc14e..f410994a2 100644
--- a/utils/lcd4linux/Makefile
+++ b/utils/lcd4linux/Makefile
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lcd4linux
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/feckert/lcd4linux
diff --git a/utils/lcd4linux/patches/171-allow-to-specify-drv_generic_graphic_real_clear.patch b/utils/lcd4linux/patches/171-allow-to-specify-drv_generic_graphic_real_clear.patch
index 5a2664307..109f11e0b 100644
--- a/utils/lcd4linux/patches/171-allow-to-specify-drv_generic_graphic_real_clear.patch
+++ b/utils/lcd4linux/patches/171-allow-to-specify-drv_generic_graphic_real_clear.patch
@@ -38,7 +38,7 @@
  extern void (*drv_generic_graphic_real_blit) (const int row, const int col, const int height, const int width);
  
 +/* these functions can be implemented by the real driver */
-+void (*drv_generic_graphic_real_clear) (const RGBA rgba);
++extern void (*drv_generic_graphic_real_clear) (const RGBA rgba);
 +
  /* helper function to get pixel color or gray value */
  extern RGBA drv_generic_graphic_rgb(const int row, const int col);