lvm2: update to version 2.03.12
Two notable changes are devices file and metadata based autoactivation. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
c241cb12bb
commit
dc27d43f29
4 changed files with 28 additions and 8 deletions
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=LVM2
|
||||
PKG_VERSION:=2.03.11
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=2.03.12
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=https://sourceware.org/pub/lvm2
|
||||
PKG_HASH:=842c4510d4653990927d4518a5bf2743126a37531671a05842cdaf8d54bb9dd4
|
||||
PKG_HASH:=76075cf2a2dd12ef526a583f0b3c72a6deaa10691fab28216b0821d01cff0cea
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/lvm2-$(BUILD_VARIANT)/$(PKG_NAME).$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/commands/toolcontext.c
|
||||
+++ b/lib/commands/toolcontext.c
|
||||
@@ -1605,7 +1605,7 @@ struct cmd_context *create_toolcontext(u
|
||||
@@ -1619,7 +1619,7 @@ struct cmd_context *create_toolcontext(u
|
||||
/* FIXME Make this configurable? */
|
||||
reset_lvm_errno(1);
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
/* Set in/out stream buffering before glibc */
|
||||
if (set_buffering
|
||||
#ifdef SYS_gettid
|
||||
@@ -1986,7 +1986,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
@@ -2006,7 +2006,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
|
||||
if (cmd->pending_delete_mem)
|
||||
dm_pool_destroy(cmd->pending_delete_mem);
|
||||
|
@ -20,7 +20,7 @@
|
|||
if (is_valid_fd(STDIN_FILENO) &&
|
||||
--- a/tools/lvmcmdline.c
|
||||
+++ b/tools/lvmcmdline.c
|
||||
@@ -3235,6 +3235,7 @@ int lvm_split(char *str, int *argc, char
|
||||
@@ -3339,6 +3339,7 @@ int lvm_split(char *str, int *argc, char
|
||||
/* Make sure we have always valid filedescriptors 0,1,2 */
|
||||
static int _check_standard_fds(void)
|
||||
{
|
||||
|
@ -28,7 +28,7 @@
|
|||
int err = is_valid_fd(STDERR_FILENO);
|
||||
|
||||
if (!is_valid_fd(STDIN_FILENO) &&
|
||||
@@ -3261,6 +3262,12 @@ static int _check_standard_fds(void)
|
||||
@@ -3365,6 +3366,12 @@ static int _check_standard_fds(void)
|
||||
strerror(errno));
|
||||
return 0;
|
||||
}
|
||||
|
|
|
@ -15,7 +15,7 @@ on standard C libraries without O_DIRECT_SUPPORT.
|
|||
|
||||
--- a/lib/device/dev-io.c
|
||||
+++ b/lib/device/dev-io.c
|
||||
@@ -379,7 +379,7 @@ int dev_open_flags(struct device *dev, i
|
||||
@@ -380,7 +380,7 @@ int dev_open_flags(struct device *dev, i
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
|
20
utils/lvm2/patches/005-missing-include-sys-file.patch
Normal file
20
utils/lvm2/patches/005-missing-include-sys-file.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- a/lib/device/dev-cache.c
|
||||
+++ b/lib/device/dev-cache.c
|
||||
@@ -29,6 +29,7 @@
|
||||
#include <unistd.h>
|
||||
#include <dirent.h>
|
||||
#include <locale.h>
|
||||
+#include <sys/file.h>
|
||||
|
||||
struct dev_iter {
|
||||
struct btree_iter *current;
|
||||
--- a/tools/lvmdevices.c
|
||||
+++ b/tools/lvmdevices.c
|
||||
@@ -15,6 +15,7 @@
|
||||
#include "tools.h"
|
||||
#include "lib/cache/lvmcache.h"
|
||||
#include "lib/device/device_id.h"
|
||||
+#include <sys/file.h>
|
||||
|
||||
static void _search_devs_for_pvids(struct cmd_context *cmd, struct dm_list *search_pvids, struct dm_list *found_devs)
|
||||
{
|
Loading…
Reference in a new issue