moreutils: fix compilation with uClibc-ng
getloadavg is missing not just under cygwin. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
d8d06cfca2
commit
d9bb2dc5f6
2 changed files with 12 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=moreutils
|
||||
PKG_VERSION:=0.63
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://git.kitenet.net/index.cgi/moreutils.git/snapshot
|
||||
|
|
11
utils/moreutils/patches/010-uclibc.patch
Normal file
11
utils/moreutils/patches/010-uclibc.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/parallel.c
|
||||
+++ b/parallel.c
|
||||
@@ -241,7 +241,7 @@ pid_t create_pipe_child(int *fd, int orig_fd)
|
||||
return pipe_child(fds[0], orig_fd);
|
||||
}
|
||||
|
||||
-#if defined(__CYGWIN__)
|
||||
+#if defined(__CYGWIN__) || defined(__UCLIBC__)
|
||||
int getloadavg(double loadavg[], int nelem) {
|
||||
int fd, n, elem;
|
||||
char buf[128];
|
Loading…
Reference in a new issue