lxc: update to 5.0.1
Bump to latest and update Makefile to use meson which is upstream's standard. Deleted unneeded 010-Remove-distro-check.patch (reference to configure). Build system: x86_64 Build-tested: bcm2711/RPi4B Run-tested: bcm2711/RPi4B Signed-off-by: John Audia <therealgraysky@proton.me>
This commit is contained in:
parent
73e02994fb
commit
d957a2293b
2 changed files with 16 additions and 63 deletions
|
@ -9,22 +9,31 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lxc
|
||||
PKG_VERSION:=4.0.12
|
||||
PKG_VERSION:=5.0.1
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://linuxcontainers.org/downloads/lxc/
|
||||
PKG_HASH:=db242f8366fc63e8c7588bb2017b354173cf3c4b20abc18780debdc48b14d3ef
|
||||
PKG_HASH:=d8195423bb1e206f8521d24b6cde4789f043960c7cf065990a9cf741dcfd4222
|
||||
|
||||
PKG_MAINTAINER:=Marko Ratkaj <markoratkaj@gmail.com>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later BSD-2-Clause GPL-2.0
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_LICENSE_FILES:=COPYING LICENSE.GPL2 LICENSE.LGPL2.1
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
MESON_ARGS += \
|
||||
-Db_lto=$(if $(findstring mips,$(CONFIG_ARCH)),false,true) \
|
||||
-Dwerror=false \
|
||||
-Dinit-script=sysvinit \
|
||||
-Dman=false \
|
||||
-Dapparmor=false \
|
||||
-Dselinux=false \
|
||||
-Dseccomp=$(if $(CONFIG_LXC_SECCOMP),true,false) \
|
||||
-Dexamples=false \
|
||||
-Db_pie=true
|
||||
|
||||
LXC_APPLETS_BIN += \
|
||||
attach autostart cgroup copy config console create destroy device \
|
||||
|
@ -135,17 +144,6 @@ define Package/lxc-init
|
|||
DEPENDS+= +liblxc
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-werror \
|
||||
--disable-rpath \
|
||||
--disable-doc \
|
||||
--disable-api-docs \
|
||||
--disable-apparmor \
|
||||
--disable-selinux \
|
||||
--$(if $(CONFIG_LXC_SECCOMP),en,dis)able-seccomp \
|
||||
--enable-capabilities \
|
||||
--disable-examples
|
||||
|
||||
ifdef CONFIG_USE_MIPS16
|
||||
TARGET_CFLAGS += -minterlink-mips16
|
||||
endif
|
||||
|
@ -262,7 +260,6 @@ define GenPlugin
|
|||
$$(eval $$(call BuildPackage,lxc-$(1)))
|
||||
endef
|
||||
|
||||
|
||||
$(eval $(call BuildPackage,lxc))
|
||||
$(eval $(call BuildPackage,lxc-common))
|
||||
$(eval $(call BuildPackage,lxc-hooks))
|
||||
|
@ -273,5 +270,5 @@ $(eval $(call BuildPackage,lxc-init))
|
|||
$(eval $(call BuildPackage,lxc-auto))
|
||||
$(eval $(call BuildPackage,lxc-unprivileged))
|
||||
$(foreach u,$(LXC_APPLETS_BIN),$(eval $(call GenPlugin,$(u),$(DEPENDS_APPLETS),"/usr/bin")))
|
||||
$(foreach u,$(LXC_APPLETS_LIB),$(eval $(call GenPlugin,$(u),$(DEPENDS_APPLETS),"/usr/lib/lxc")))
|
||||
$(foreach u,$(LXC_APPLETS_LIB),$(eval $(call GenPlugin,$(u),$(DEPENDS_APPLETS),"/usr/libexec/lxc")))
|
||||
$(foreach u,$(LXC_SCRIPTS),$(eval $(call GenPlugin,$(u),,"/usr/bin")))
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
From 9f550ca53801b2b9c6c1c7a4d02ad525c704b145 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Marko <robert.marko@sartura.hr>
|
||||
Date: Thu, 14 May 2020 13:40:53 +0200
|
||||
Subject: [PATCH] Remove distro check
|
||||
|
||||
Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
||||
---
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -79,34 +79,6 @@ esac
|
||||
LT_INIT
|
||||
AC_SUBST([LIBTOOL_DEPS])
|
||||
|
||||
-# Detect the distribution. This is used for the default configuration and
|
||||
-# for some distro-specific build options.
|
||||
-AC_MSG_CHECKING([host distribution])
|
||||
-AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, redhatenterpriseserver, oracle, centos, fedora, suse, gentoo, debian, arch, slackware, plamo, paldo, openmandriva, pardus, sparclinux, altlinux.]))
|
||||
-if type lsb_release >/dev/null 2>&1 && test "z$with_distro" = "z"; then
|
||||
- with_distro=$(lsb_release -is)
|
||||
-fi
|
||||
-if test "z$with_distro" = "z"; then
|
||||
- AC_CHECK_FILE(/etc/redhat-release,with_distro="redhat")
|
||||
- AC_CHECK_FILE(/etc/oracle-release,with_distro="oracle")
|
||||
- AC_CHECK_FILE(/etc/sparclinux-release,with_distro="sparclinux")
|
||||
- AC_CHECK_FILE(/etc/centos-release,with_distro="centos")
|
||||
- AC_CHECK_FILE(/etc/fedora-release,with_distro="fedora")
|
||||
- AC_CHECK_FILE(/etc/SuSE-release,with_distro="suse")
|
||||
- AC_CHECK_FILE(/etc/gentoo-release,with_distro="gentoo")
|
||||
- AC_CHECK_FILE(/etc/debian_version,with_distro="debian")
|
||||
- AC_CHECK_FILE(/etc/arch-release,with_distro="arch")
|
||||
- AC_CHECK_FILE(/etc/slackware-version,with_distro="slackware")
|
||||
- AC_CHECK_FILE(/etc/plamo-version,with_distro="plamo")
|
||||
- AC_CHECK_FILE(/etc/frugalware-release,with_distro="frugalware")
|
||||
- AC_CHECK_FILE(/etc/mandrakelinux-release, with_distro="openmandriva")
|
||||
- AC_CHECK_FILE(/etc/mandriva-release,with_distro="openmandriva")
|
||||
- AC_CHECK_FILE(/etc/pardus-release,with_distro="pardus")
|
||||
- AC_CHECK_FILE(/etc/altlinux-release,with_distro="altlinux")
|
||||
- AC_CHECK_FILE(/etc/pld-release,with_distro="pld")
|
||||
-fi
|
||||
-with_distro=$(echo ${with_distro} | tr '[[:upper:]]' '[[:lower:]]')
|
||||
-
|
||||
if test "z$with_distro" = "zforsparc"; then
|
||||
with_distro="sparclinux"
|
||||
fi
|
Loading…
Reference in a new issue