Merge pull request #1392 from jow-/bridge-must-compat

bridge-utils: fix musl compatibility
This commit is contained in:
Jo-Philipp Wich 2015-06-17 02:31:50 +02:00
commit d94d9bd232
2 changed files with 12 additions and 1 deletions

View file

@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=bridge-utils PKG_NAME:=bridge-utils
PKG_VERSION:=1.5 PKG_VERSION:=1.5
PKG_RELEASE:=4 PKG_RELEASE:=5
PKG_SOURCE_PROTO:=git PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git

View file

@ -0,0 +1,11 @@
--- a/libbridge/libbridge.h
+++ b/libbridge/libbridge.h
@@ -19,6 +19,8 @@
#ifndef _LIBBRIDGE_H
#define _LIBBRIDGE_H
+#include <sys/types.h>
+#include <sys/select.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <linux/if.h>