gpsd: update to 3.21
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
17f2a76a79
commit
d916233928
5 changed files with 20 additions and 32 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gpsd
|
||||
PKG_VERSION:=3.20
|
||||
PKG_VERSION:=3.21
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
|
||||
PKG_HASH:=3998a5cbb728e97f896f46c3c83301b1e6c5d859393e58c2fad8c5426774d571
|
||||
PKG_HASH:=5512a7d3c2e86be83c5555652e5b4cc9049e8878a4320be7f039eb1a7203e5f0
|
||||
|
||||
PKG_MAINTAINER:=Pushpal Sidhu <psidhu.devel@gmail.com>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -8,19 +8,12 @@
|
|||
import SCons
|
||||
|
||||
|
||||
@@ -669,6 +668,7 @@ def GetPythonValue(context, name, imp, e
|
||||
context.Message('Obtaining Python %s... ' % name)
|
||||
context.sconf.cached = 0 # Avoid bogus "(cached)"
|
||||
if not env['target_python']:
|
||||
+ from distutils import sysconfig
|
||||
status, value = 0, str(eval(expr))
|
||||
else:
|
||||
command = [target_python_path, '-c', '%s; print(%s)' % (imp, expr)]
|
||||
@@ -1218,6 +1218,7 @@ if helping:
|
||||
@@ -303,7 +302,7 @@ EnsureSConsVersion(2, 3, 0)
|
||||
EnsurePythonVersion(2, 6)
|
||||
|
||||
# If helping just get usable config info from the local Python
|
||||
target_python_path = ''
|
||||
+ from distutils import sysconfig
|
||||
py_config_text = str(eval(PYTHON_CONFIG_CALL))
|
||||
python_libdir = str(eval(PYTHON_LIBDIR_CALL))
|
||||
|
||||
-PYTHON_SYSCONFIG_IMPORT = 'from distutils import sysconfig'
|
||||
+PYTHON_SYSCONFIG_IMPORT = ''
|
||||
|
||||
# Utility productions
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/SConstruct
|
||||
+++ b/SConstruct
|
||||
@@ -874,6 +874,10 @@ else:
|
||||
@@ -1068,6 +1068,10 @@ else:
|
||||
ncurseslibs += pkg_config('tinfo', rpath_hack=True)
|
||||
# It's not yet known whether rpath_hack is appropriate for
|
||||
# ncurses5-config.
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
--- a/SConstruct
|
||||
+++ b/SConstruct
|
||||
@@ -1047,12 +1047,6 @@ else:
|
||||
confdefs.append("/* #undef HAVE_%s_H */\n"
|
||||
% hdr.replace("/", "_").upper())
|
||||
|
||||
- sizeof_time_t = config.CheckSizeOf("time_t")
|
||||
- confdefs.append("#define SIZEOF_TIME_T %s\n" % sizeof_time_t)
|
||||
- announce("sizeof(time_t) is %s" % sizeof_time_t)
|
||||
- if 4 >= int(sizeof_time_t):
|
||||
- announce("WARNING: time_t is too small. It will fail in 2038")
|
||||
-
|
||||
# check function after libraries, because some function require libraries
|
||||
# for example clock_gettime() require librt on Linux glibc < 2.17
|
||||
for f in ("cfmakeraw", "clock_gettime", "daemon", "fcntl", "fork",
|
10
utils/gpsd/test.sh
Normal file
10
utils/gpsd/test.sh
Normal file
|
@ -0,0 +1,10 @@
|
|||
#!/bin/sh
|
||||
|
||||
case "$1" in
|
||||
"gpsd")
|
||||
gpsd -V 2>&1 | grep "$2"
|
||||
;;
|
||||
"gpsd-clients")
|
||||
cgps -V 2>&1 | grep "$2"
|
||||
;;
|
||||
esac
|
Loading…
Reference in a new issue