fish: update to 3.1.0
Remove upstreamed patches.
Added missing libatomic dependency.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit bee0bfe862
)
This commit is contained in:
parent
aae54e90ca
commit
d8c836f6a5
3 changed files with 4 additions and 82 deletions
|
@ -5,12 +5,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=fish
|
||||
PKG_VERSION:=3.0.2
|
||||
PKG_RELEASE:=6
|
||||
PKG_VERSION:=3.1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/fish-shell/fish-shell/releases/download/$(PKG_VERSION)
|
||||
PKG_HASH:=14728ccc6b8e053d01526ebbd0822ca4eb0235e6487e832ec1d0d22f1395430e
|
||||
PKG_HASH:=e5db1e6839685c56f172e1000c138e290add4aa521f187df4cd79d4eab294368
|
||||
|
||||
PKG_MAINTAINER:=Curtis Jiang <jqqqqqqqqqq@gmail.com>, Hao Dong <halbertdong@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
@ -28,7 +28,7 @@ define Package/fish
|
|||
CATEGORY:=Utilities
|
||||
SUBMENU:=Shells
|
||||
TITLE:=A smart and user-friendly command line shell
|
||||
DEPENDS:=+libncurses +libstdcpp +librt +libpcre2-32 @!USE_UCLIBC
|
||||
DEPENDS:=+libncurses +libstdcpp +libatomic +librt +libpcre2-32 @!USE_UCLIBC
|
||||
URL:=https://fishshell.com
|
||||
endef
|
||||
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
diff --git a/share/functions/prompt_hostname.fish b/share/functions/prompt_hostname.fish
|
||||
index 225f437c..dc7f1cf8 100644
|
||||
--- a/share/functions/prompt_hostname.fish
|
||||
+++ b/share/functions/prompt_hostname.fish
|
||||
@@ -1,4 +1,4 @@
|
||||
function prompt_hostname
|
||||
# return the short hostname only by default (#4804)
|
||||
- string replace -r "\..*" "" $hostname
|
||||
+ string replace -r "\..*" "" (uname -n)
|
||||
end
|
||||
diff --git a/share/tools/web_config/sample_prompts/pythonista.fish b/share/tools/web_config/sample_prompts/pythonista.fish
|
||||
index 9529035c..57ffaf86 100644
|
||||
--- a/share/tools/web_config/sample_prompts/pythonista.fish
|
||||
+++ b/share/tools/web_config/sample_prompts/pythonista.fish
|
||||
@@ -7,7 +7,7 @@ function fish_prompt
|
||||
set -g VIRTUAL_ENV_DISABLE_PROMPT true
|
||||
end
|
||||
set_color yellow
|
||||
- printf '%s' (whoami)
|
||||
+ printf '%s' (id -un)
|
||||
set_color normal
|
||||
printf ' at '
|
||||
|
||||
diff --git a/share/tools/web_config/sample_prompts/screen_savvy.fish b/share/tools/web_config/sample_prompts/screen_savvy.fish
|
||||
index 411a5501..5cdcfb69 100644
|
||||
--- a/share/tools/web_config/sample_prompts/screen_savvy.fish
|
||||
+++ b/share/tools/web_config/sample_prompts/screen_savvy.fish
|
||||
@@ -2,8 +2,8 @@
|
||||
# author: Matthias
|
||||
function fish_prompt -d "Write out the prompt"
|
||||
if test -z $WINDOW
|
||||
- printf '%s%s@%s%s%s%s%s> ' (set_color yellow) (whoami) (set_color purple) (prompt_hostname) (set_color $fish_color_cwd) (prompt_pwd) (set_color normal)
|
||||
+ printf '%s%s@%s%s%s%s%s> ' (set_color yellow) (id -un) (set_color purple) (prompt_hostname) (set_color $fish_color_cwd) (prompt_pwd) (set_color normal)
|
||||
else
|
||||
- printf '%s%s@%s%s%s(%s)%s%s%s> ' (set_color yellow) (whoami) (set_color purple) (prompt_hostname) (set_color white) (echo $WINDOW) (set_color $fish_color_cwd) (prompt_pwd) (set_color normal)
|
||||
+ printf '%s%s@%s%s%s(%s)%s%s%s> ' (set_color yellow) (id -un) (set_color purple) (prompt_hostname) (set_color white) (echo $WINDOW) (set_color $fish_color_cwd) (prompt_pwd) (set_color normal)
|
||||
end
|
||||
end
|
||||
diff --git a/share/tools/web_config/sample_prompts/terlar.fish b/share/tools/web_config/sample_prompts/terlar.fish
|
||||
index d49ef340..59b3d267 100644
|
||||
--- a/share/tools/web_config/sample_prompts/terlar.fish
|
||||
+++ b/share/tools/web_config/sample_prompts/terlar.fish
|
||||
@@ -6,7 +6,7 @@ function fish_prompt --description 'Write out the prompt'
|
||||
|
||||
# User
|
||||
set_color $fish_color_user
|
||||
- echo -n (whoami)
|
||||
+ echo -n (id -un)
|
||||
set_color normal
|
||||
|
||||
echo -n '@'
|
|
@ -1,27 +0,0 @@
|
|||
From c132a2aa53f3a4ca0ab26395a4936ecf3fd030f2 Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Fri, 13 Dec 2019 21:50:06 -0800
|
||||
Subject: [PATCH] common.cpp: Don't always include cxxabi.h
|
||||
|
||||
cxxabi.h is not available with LLVM's libcxx
|
||||
---
|
||||
src/common.cpp | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/common.cpp b/src/common.cpp
|
||||
index cfa4cb0d81..96873f17a9 100644
|
||||
--- a/src/common.cpp
|
||||
+++ b/src/common.cpp
|
||||
@@ -1,8 +1,11 @@
|
||||
// Various functions, mostly string utilities, that are used by most parts of fish.
|
||||
#include "config.h"
|
||||
|
||||
-#include <ctype.h>
|
||||
+#ifdef HAVE_BACKTRACE_SYMBOLS
|
||||
#include <cxxabi.h>
|
||||
+#endif
|
||||
+
|
||||
+#include <ctype.h>
|
||||
#include <dlfcn.h>
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
Loading…
Reference in a new issue