Merge pull request #12705 from neheb/htp
htop: fix compilation with GCC10
This commit is contained in:
commit
d8c79fd52a
2 changed files with 39 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=htop
|
PKG_NAME:=htop
|
||||||
PKG_VERSION:=2.2.0
|
PKG_VERSION:=2.2.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://hisham.hm/htop/releases/$(PKG_VERSION)/
|
PKG_SOURCE_URL:=https://hisham.hm/htop/releases/$(PKG_VERSION)/
|
||||||
|
|
38
admin/htop/patches/010-gcc10.patch
Normal file
38
admin/htop/patches/010-gcc10.patch
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
From ee711740d2809e7aa3ebd57d58bfc02b1e9b034b Mon Sep 17 00:00:00 2001
|
||||||
|
From: David Seifert <soap@gentoo.org>
|
||||||
|
Date: Thu, 23 Jan 2020 17:27:10 +0100
|
||||||
|
Subject: [PATCH] Fix GCC 10 switch to `-fno-common` default
|
||||||
|
|
||||||
|
---
|
||||||
|
CRT.h | 6 +++---
|
||||||
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/CRT.h b/CRT.h
|
||||||
|
index 933fe068..65998ac6 100644
|
||||||
|
--- a/CRT.h
|
||||||
|
+++ b/CRT.h
|
||||||
|
@@ -140,7 +140,7 @@ extern const char **CRT_treeStr;
|
||||||
|
|
||||||
|
extern int CRT_delay;
|
||||||
|
|
||||||
|
-int* CRT_colors;
|
||||||
|
+extern int* CRT_colors;
|
||||||
|
|
||||||
|
extern int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT];
|
||||||
|
|
||||||
|
@@ -150,13 +150,13 @@ extern int CRT_scrollHAmount;
|
||||||
|
|
||||||
|
extern int CRT_scrollWheelVAmount;
|
||||||
|
|
||||||
|
-char* CRT_termType;
|
||||||
|
+extern char* CRT_termType;
|
||||||
|
|
||||||
|
// TODO move color scheme to Settings, perhaps?
|
||||||
|
|
||||||
|
extern int CRT_colorScheme;
|
||||||
|
|
||||||
|
-void *backtraceArray[128];
|
||||||
|
+extern void *backtraceArray[128];
|
||||||
|
|
||||||
|
#if HAVE_SETUID_ENABLED
|
||||||
|
|
Loading…
Reference in a new issue