utils/tar: Fix tar build dependency and CVE-2016-6321
Should be PKG_BUILD_DEPENDS not BUILD_DEPENDS Signed-off-by: Daniel Dickinson <lede@daniel.thecshore.com> Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
6efdda825b
commit
d811a84077
2 changed files with 32 additions and 2 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=tar
|
||||
PKG_VERSION:=1.29
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
||||
|
@ -21,7 +21,7 @@ PKG_LICENSE_FILES:=COPYING
|
|||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
BUILD_DEPENDS:=xz
|
||||
PKG_BUILD_DEPENDS:=xz
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
30
utils/tar/patches/001-CVE-2016-6321.patch
Normal file
30
utils/tar/patches/001-CVE-2016-6321.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
From 7340f67b9860ea0531c1450e5aa261c50f67165d Mon Sep 17 00:00:00 2001
|
||||
From: Paul Eggert <eggert@Penguin.CS.UCLA.EDU>
|
||||
Date: Sat, 29 Oct 2016 21:04:40 -0700
|
||||
Subject: When extracting, skip ".." members
|
||||
|
||||
* src/extract.c (extract_archive): Skip members whose names
|
||||
contain "..".
|
||||
--- a/src/extract.c
|
||||
+++ b/src/extract.c
|
||||
@@ -1629,12 +1629,20 @@ extract_archive (void)
|
||||
{
|
||||
char typeflag;
|
||||
tar_extractor_t fun;
|
||||
+ bool skip_dotdot_name;
|
||||
|
||||
fatal_exit_hook = extract_finish;
|
||||
|
||||
set_next_block_after (current_header);
|
||||
|
||||
+ skip_dotdot_name = (!absolute_names_option
|
||||
+ && contains_dot_dot (current_stat_info.orig_file_name));
|
||||
+ if (skip_dotdot_name)
|
||||
+ ERROR ((0, 0, _("%s: Member name contains '..'"),
|
||||
+ quotearg_colon (current_stat_info.orig_file_name)));
|
||||
+
|
||||
if (!current_stat_info.file_name[0]
|
||||
+ || skip_dotdot_name
|
||||
|| (interactive_option
|
||||
&& !confirm ("extract", current_stat_info.file_name)))
|
||||
{
|
Loading…
Reference in a new issue