i2pd: update to version 2.48.0
Signed-off-by: R4SAS I2P <r4sas@i2pmail.org>
This commit is contained in:
parent
3ee4f030b5
commit
d7b0d3f83d
2 changed files with 31 additions and 31 deletions
|
@ -1,7 +1,7 @@
|
|||
#
|
||||
# Copyright (C) 2015, 2016 gxcreator
|
||||
# Copyright (C) 2017 OpenWrt.org
|
||||
# Copyright (C) 2021-2022 PurpleI2P team
|
||||
# Copyright (C) 2021-2023 PurpleI2P team
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -10,13 +10,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=i2pd
|
||||
PKG_VERSION:=2.46.1
|
||||
PKG_VERSION:=2.48.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/PurpleI2P/i2pd/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=83bb5e2494d566d41ff3a85e4c93078d290d10e3cf1fbe7807bec9f0d024513e
|
||||
PKG_HASH:=ccf417aa66ce37f72ea15b7fbcff4c71e823566ea74bda696b9c1e19aae08739
|
||||
|
||||
PKG_MAINTAINER:=David Yang <mmyangfl@gmail.com>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
@ -55,7 +55,7 @@ define Package/i2pd/install
|
|||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/i2pd.init $(1)/etc/init.d/i2pd
|
||||
$(INSTALL_DIR) $(1)/usr/share/i2pd
|
||||
$(CP) $(PKG_BUILD_DIR)/contrib/certificates $(1)/usr/share/i2pd
|
||||
$(CP) $(PKG_BUILD_DIR)/contrib/certificates $(1)/usr/share/i2pd
|
||||
$(INSTALL_DIR) $(1)/etc/config
|
||||
$(INSTALL_CONF) ./files/i2pd.config $(1)/etc/config/i2pd
|
||||
$(INSTALL_DIR) $(1)/etc/i2pd
|
||||
|
|
|
@ -18,72 +18,72 @@
|
|||
-# certsdir = /var/lib/i2pd/certificates
|
||||
+certsdir = /usr/share/i2pd/certificates
|
||||
|
||||
## Where to write pidfile (default: i2pd.pid, not used in Windows)
|
||||
## Where to write pidfile (default: /run/i2pd.pid, not used in Windows)
|
||||
# pidfile = /run/i2pd.pid
|
||||
@@ -35,7 +35,7 @@
|
||||
# logfile = /var/log/i2pd/i2pd.log
|
||||
## Log messages above this level (debug, info, *warn, error, none)
|
||||
## Log messages above this level (debug, info, *warn, error, critical, none)
|
||||
## If you set it to none, logging will be disabled
|
||||
-# loglevel = warn
|
||||
+loglevel = none
|
||||
## Write full CLF-formatted date and time to log (default: write only time)
|
||||
# logclftime = true
|
||||
|
||||
@@ -115,9 +115,9 @@ ssu = false
|
||||
@@ -118,9 +118,9 @@ ipv6 = false
|
||||
[http]
|
||||
## Web Console settings
|
||||
## Uncomment and set to 'false' to disable Web Console
|
||||
## Enable the Web Console (default: true)
|
||||
-# enabled = true
|
||||
+enabled = true
|
||||
## Address and port service will listen on
|
||||
-address = 127.0.0.1
|
||||
## Address and port service will listen on (default: 127.0.0.1:7070)
|
||||
-# address = 127.0.0.1
|
||||
+address = 192.168.1.1
|
||||
port = 7070
|
||||
## Path to web console, default "/"
|
||||
# port = 7070
|
||||
## Path to web console (default: /)
|
||||
# webroot = /
|
||||
@@ -135,9 +135,9 @@ port = 7070
|
||||
@@ -138,9 +138,9 @@ ipv6 = false
|
||||
|
||||
[httpproxy]
|
||||
## Uncomment and set to 'false' to disable HTTP Proxy
|
||||
## Enable the HTTP proxy (default: true)
|
||||
-# enabled = true
|
||||
+enabled = true
|
||||
## Address and port service will listen on
|
||||
-address = 127.0.0.1
|
||||
## Address and port service will listen on (default: 127.0.0.1:4444)
|
||||
-# address = 127.0.0.1
|
||||
+address = 192.168.1.1
|
||||
port = 4444
|
||||
## Optional keys file for proxy local destination
|
||||
# port = 4444
|
||||
## Optional keys file for proxy local destination (default: http-proxy-keys.dat)
|
||||
# keys = http-proxy-keys.dat
|
||||
@@ -151,9 +151,9 @@ port = 4444
|
||||
@@ -154,9 +154,9 @@ ipv6 = false
|
||||
|
||||
[socksproxy]
|
||||
## Uncomment and set to 'false' to disable SOCKS Proxy
|
||||
## Enable the SOCKS proxy (default: true)
|
||||
-# enabled = true
|
||||
+enabled = true
|
||||
## Address and port service will listen on
|
||||
-address = 127.0.0.1
|
||||
## Address and port service will listen on (default: 127.0.0.1:4447)
|
||||
-# address = 127.0.0.1
|
||||
+address = 192.168.1.1
|
||||
port = 4447
|
||||
## Optional keys file for proxy local destination
|
||||
# port = 4447
|
||||
## Optional keys file for proxy local destination (default: socks-proxy-keys.dat)
|
||||
# keys = socks-proxy-keys.dat
|
||||
@@ -167,7 +167,7 @@ port = 4447
|
||||
@@ -170,7 +170,7 @@ ipv6 = false
|
||||
|
||||
[sam]
|
||||
## Comment or set to 'false' to disable SAM Bridge
|
||||
-enabled = true
|
||||
## Enable the SAM bridge (default: true)
|
||||
-# enabled = false
|
||||
+enabled = false
|
||||
## Address and port service will listen on
|
||||
## Address and ports service will listen on (default: 127.0.0.1:7656, udp: 7655)
|
||||
# address = 127.0.0.1
|
||||
# port = 7656
|
||||
@@ -202,7 +202,7 @@ enabled = true
|
||||
@@ -206,7 +206,7 @@ ipv6 = false
|
||||
|
||||
[upnp]
|
||||
## Enable or disable UPnP: automatic port forwarding (enabled by default in WINDOWS, ANDROID)
|
||||
-# enabled = false
|
||||
+enabled = false
|
||||
## Name i2pd appears in UPnP forwardings list (default = I2Pd)
|
||||
## Name i2pd appears in UPnP forwardings list (default: I2Pd)
|
||||
# name = I2Pd
|
||||
|
||||
@@ -244,7 +244,7 @@ verify = true
|
||||
@@ -248,7 +248,7 @@ verify = true
|
||||
[limits]
|
||||
## Maximum active transit sessions (default: 5000)
|
||||
## This value is doubled if floodfill mode is enabled!
|
||||
|
|
Loading…
Reference in a new issue