keyutils: add new package
This is based on earlier work by Tobias Waldvogel. Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
77d8472ed5
commit
d71da004d9
3 changed files with 79 additions and 0 deletions
47
libs/keyutils/Makefile
Normal file
47
libs/keyutils/Makefile
Normal file
|
@ -0,0 +1,47 @@
|
|||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=keyutils
|
||||
PKG_VERSION:=1.5.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://people.redhat.com/dhowells/keyutils/
|
||||
PKG_HASH:=115c3deae7f181778fd0e0ffaa2dad1bf1fe2f5677cf2e0e348cdb7a1c93afb6
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libkeyutils
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Key utilities library
|
||||
URL:=http://people.redhat.com/dhowells/keyutils/
|
||||
endef
|
||||
|
||||
define Package/keyutils/description
|
||||
Key utilities library
|
||||
endef
|
||||
|
||||
define Build/Install
|
||||
make -C $(PKG_BUILD_DIR) DESTDIR=$(PKG_INSTALL_DIR) LIBDIR=/usr/lib install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libkeyutils.{a,so*} $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libkeyutils/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libkeyutils.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libkeyutils))
|
13
libs/keyutils/patches/03-cifs.patch
Normal file
13
libs/keyutils/patches/03-cifs.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
Author: Marcus Meissner <meissner@suse.de>
|
||||
Description: Added 2 cifs helpers to request-key.conf (for CIFS DFS support)
|
||||
|
||||
diff -Naurp keyutils.orig/request-key.conf keyutils/request-key.conf
|
||||
--- keyutils.orig/request-key.conf 2011-08-22 11:46:30.332025250 +0200
|
||||
+++ keyutils/request-key.conf 2011-08-22 11:49:40.096967441 +0200
|
||||
@@ -38,4 +38,6 @@ create user debug:* expired
|
||||
create user debug:* revoked /bin/keyctl reject %k 30 %c %S
|
||||
create user debug:loop:* * |/bin/cat
|
||||
create user debug:* * /usr/share/keyutils/request-key-debug.sh %k %d %c %S
|
||||
+create cifs.spnego * * /usr/sbin/cifs.upcall -c %k
|
||||
+create dns_resolver * * /usr/sbin/cifs.upcall %k
|
||||
negate * * * /bin/keyctl negate %k 30 %S
|
19
libs/keyutils/patches/04-cflags.patch
Normal file
19
libs/keyutils/patches/04-cflags.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
Author: Nobuhiro Iwamatsu <iwamatsu@debian.org>
|
||||
Description: Avoid setting Intel Architecture specific CFLAGS (Closes: #638925).
|
||||
|
||||
diff -Naurp keyutils.orig/Makefile keyutils/Makefile
|
||||
--- keyutils.orig/Makefile 2011-08-22 11:51:20.521464216 +0200
|
||||
+++ keyutils/Makefile 2011-08-24 19:17:09.855361713 +0200
|
||||
@@ -56,12 +56,10 @@ BUILDFOR := $(shell file /usr/bin/make |
|
||||
LNS := ln -sf
|
||||
|
||||
ifeq ($(BUILDFOR),32-bit)
|
||||
-CFLAGS += -m32
|
||||
LIBDIR := /lib
|
||||
USRLIBDIR := /usr/lib
|
||||
else
|
||||
ifeq ($(BUILDFOR),64-bit)
|
||||
-CFLAGS += -m64
|
||||
LIBDIR := /lib64
|
||||
USRLIBDIR := /usr/lib64
|
||||
endif
|
Loading…
Reference in a new issue