apfree-wifidog: update to 4.08.1771
Signed-off-by: Dengfeng Liu <dfliuc@isoftstone.com>
This commit is contained in:
parent
41d9951575
commit
d6926c1b32
3 changed files with 2 additions and 56 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=apfree-wifidog
|
||||
PKG_VERSION:=3.11.1716
|
||||
PKG_VERSION:=4.08.1771
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/liudf0716/apfree_wifidog.git
|
||||
PKG_SOURCE_VERSION:=$(PKG_VERSION)
|
||||
PKG_MIRROR_HASH:=76eda57e40b919091281305344bc57fc732a779d7944f57bd5de87914ba127d1
|
||||
PKG_MIRROR_HASH:=0fadb7a0e139bf4a5c6daffdd0f200ee2a4c903aea71e46bc19212b054ca71a7
|
||||
|
||||
PKG_MAINTAINER:=Dengfeng Liu <liudf0716@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- a/src/gateway.c
|
||||
+++ b/src/gateway.c
|
||||
@@ -78,10 +78,14 @@ openssl_init(void)
|
||||
ERR_load_crypto_strings();
|
||||
SSL_load_error_strings();
|
||||
OpenSSL_add_all_algorithms();
|
||||
-#endif
|
||||
debug (LOG_DEBUG, "Using OpenSSL version \"%s\"\nand libevent version \"%s\"\n",
|
||||
SSLeay_version (SSLEAY_VERSION),
|
||||
event_get_version ());
|
||||
+#else
|
||||
+ debug (LOG_DEBUG, "Using OpenSSL version \"%s\"\nand libevent version \"%s\"\n",
|
||||
+ OpenSSL_version (OPENSSL_VERSION),
|
||||
+ event_get_version ());
|
||||
+#endif
|
||||
}
|
||||
|
||||
static void
|
|
@ -1,36 +0,0 @@
|
|||
--- a/src/conf.h
|
||||
+++ b/src/conf.h
|
||||
@@ -430,12 +430,12 @@ void clear_trusted_ip_list(void);
|
||||
void del_trusted_ip_list(const char *);
|
||||
|
||||
// online clients
|
||||
-int g_online_clients; // total connected client count
|
||||
-char *g_version;
|
||||
-char *g_type; // hardware type
|
||||
-char *g_name; // firmware name
|
||||
-char *g_channel_path;
|
||||
-char *g_ssid;
|
||||
+extern int g_online_clients; // total connected client count
|
||||
+extern char *g_version;
|
||||
+extern char *g_type; // hardware type
|
||||
+extern char *g_name; // firmware name
|
||||
+extern char *g_channel_path;
|
||||
+extern char *g_ssid;
|
||||
|
||||
#define LOCK_DOMAIN() do { \
|
||||
debug(LOG_INFO, "Locking domain"); \
|
||||
--- a/src/ping_thread.c
|
||||
+++ b/src/ping_thread.c
|
||||
@@ -43,6 +43,12 @@
|
||||
#include "wd_client.h"
|
||||
|
||||
extern time_t started_time;
|
||||
+int g_online_clients;
|
||||
+char *g_version;
|
||||
+char *g_type;
|
||||
+char *g_name;
|
||||
+char *g_channel_path;
|
||||
+char *g_ssid;
|
||||
|
||||
static void fw_init_delay();
|
||||
static void ping_work_cb(evutil_socket_t, short, void *);
|
Loading…
Reference in a new issue