cmdpad: fix bad scanf format
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
a24de043b2
commit
d5d8a39b53
2 changed files with 12 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=cmdpad
|
PKG_NAME:=cmdpad
|
||||||
PKG_VERSION:=0.0.3
|
PKG_VERSION:=0.0.3
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=6
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||||
PKG_SOURCE_URL:=@SF/cmdpad
|
PKG_SOURCE_URL:=@SF/cmdpad
|
||||||
|
|
11
utils/cmdpad/patches/160-format.patch
Normal file
11
utils/cmdpad/patches/160-format.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/src/parse.c
|
||||||
|
+++ b/src/parse.c
|
||||||
|
@@ -257,7 +257,7 @@ int ParseCommand( char * pchCommandLine)
|
||||||
|
|
||||||
|
pchValue = strtok( pchValue, ",") ;
|
||||||
|
d2printf( "Value is '%s'\n", pchValue) ;
|
||||||
|
- if( (pchValue == NULL ) || ( sscanf( pchValue, "%d", &code) != 1) )
|
||||||
|
+ if( (pchValue == NULL ) || ( sscanf( pchValue, "%hu", &code) != 1) )
|
||||||
|
return -1 ;
|
||||||
|
|
||||||
|
pchValue = strtok( NULL, ",") ;
|
Loading…
Reference in a new issue