nano: update to 2.9.1
* update nano to 2.9.1 (and drop the unnecessary upstream patch) * add myself as the second maintainer Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
0ec2c1b5c5
commit
d573181fcb
2 changed files with 4 additions and 41 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=nano
|
PKG_NAME:=nano
|
||||||
PKG_VERSION:=2.8.7
|
PKG_VERSION:=2.9.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_LICENSE:=GPL-3.0+
|
PKG_LICENSE:=GPL-3.0+
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/nano
|
PKG_SOURCE_URL:=@GNU/nano
|
||||||
PKG_HASH:=fbe31746958698d73c6726ee48ad8b0612697157961a2e9aaa83b4aa53d1165a
|
PKG_HASH:=6316d52d0d26af3e79a13dcb4db1c7a4aeac61b37fd9381e801a4189a2ecba7c
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
@ -28,7 +28,8 @@ define Package/nano
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
TITLE:=An enhanced clone of the Pico text editor
|
TITLE:=An enhanced clone of the Pico text editor
|
||||||
URL:=http://www.nano-editor.org/
|
URL:=http://www.nano-editor.org/
|
||||||
MAINTAINER:=Jonathan Bennett <JBennett@incomsystems.biz>
|
MAINTAINER:=Jonathan Bennett <JBennett@incomsystems.biz>, \
|
||||||
|
Hannu Nyman <hannu.nyman@iki.fi>
|
||||||
DEPENDS:=+libncurses
|
DEPENDS:=+libncurses
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
|
|
@ -1,38 +0,0 @@
|
||||||
From 28cfab7580c42a6d6c9c5d787ce736094fd51a0c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Benno Schulenberg <bensberg@telfort.nl>
|
|
||||||
Date: Tue, 29 Aug 2017 19:28:44 +0200
|
|
||||||
Subject: tweaks: fix compilation when configured with --enable-tiny
|
|
||||||
|
|
||||||
When moving the cursor to the top-left corner, it is not necessary
|
|
||||||
to compute leftedge because firstcolumn IS the relevant leftedge.
|
|
||||||
|
|
||||||
Reported-by: Jordi Mallach <jordi@debian.org>
|
|
||||||
---
|
|
||||||
src/move.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/move.c b/src/move.c
|
|
||||||
index d138356..ce276e4 100644
|
|
||||||
--- a/src/move.c
|
|
||||||
+++ b/src/move.c
|
|
||||||
@@ -121,7 +121,7 @@ void do_page_up(void)
|
|
||||||
openfile->current = openfile->edittop;
|
|
||||||
openfile->current_y = 0;
|
|
||||||
|
|
||||||
- leftedge = leftedge_for(openfile->firstcolumn, openfile->edittop);
|
|
||||||
+ leftedge = openfile->firstcolumn;
|
|
||||||
target_column = 0;
|
|
||||||
} else
|
|
||||||
get_edge_and_target(&leftedge, &target_column);
|
|
||||||
@@ -152,7 +152,7 @@ void do_page_down(void)
|
|
||||||
openfile->current = openfile->edittop;
|
|
||||||
openfile->current_y = 0;
|
|
||||||
|
|
||||||
- leftedge = leftedge_for(openfile->firstcolumn, openfile->edittop);
|
|
||||||
+ leftedge = openfile->firstcolumn;
|
|
||||||
target_column = 0;
|
|
||||||
} else
|
|
||||||
get_edge_and_target(&leftedge, &target_column);
|
|
||||||
--
|
|
||||||
cgit v1.0-41-gc330
|
|
||||||
|
|
Loading…
Reference in a new issue