libtins: fix compilation with GCC13
Patch taken from upstream. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
d71e28de37
commit
d4ed50045f
2 changed files with 22 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=libtins
|
||||
PKG_VERSION:=4.4
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/mfontanini/libtins/tar.gz/v$(PKG_VERSION)?
|
||||
|
|
21
libs/libtins/patches/020-gcc13.patch
Normal file
21
libs/libtins/patches/020-gcc13.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
From 812be7966d445ec56e88eab512f8fd2d57152427 Mon Sep 17 00:00:00 2001
|
||||
From: Vasiliy Glazov <vascom2@gmail.com>
|
||||
Date: Tue, 24 Jan 2023 19:29:36 +0300
|
||||
Subject: [PATCH] Fix build with GCC13 (#496)
|
||||
|
||||
Due to changes in GCC13 need fix include.
|
||||
---
|
||||
include/tins/ip_address.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/include/tins/ip_address.h
|
||||
+++ b/include/tins/ip_address.h
|
||||
@@ -33,7 +33,7 @@
|
||||
#include <string>
|
||||
#include <iosfwd>
|
||||
#include <functional>
|
||||
-#include <stdint.h>
|
||||
+#include <cstdint>
|
||||
#include <tins/cxxstd.h>
|
||||
#include <tins/macros.h>
|
||||
|
Loading…
Reference in a new issue