ntpd: Fix compile with glibc 2.34
This adds a patch from Open embedded to fix compilation with glibc 2.34. This patch was taken from here: https://github.com/openembedded/meta-openembedded/blob/master/meta-networking/recipes-support/ntp/ntp/0001-libntp-Do-not-use-PTHREAD_STACK_MIN-on-glibc.patch It fixes the following build problem: work_thread.c:45:57: error: missing binary operator before token "(" 45 | #if defined(PTHREAD_STACK_MIN) && THREAD_MINSTACKSIZE < PTHREAD_STACK_MIN | ^~~~~~~~~~~~~~~~~ make[7]: *** [Makefile:892: work_thread.o] Error 1 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
71d0d9a877
commit
d4b2345802
2 changed files with 28 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ntp
|
PKG_NAME:=ntp
|
||||||
PKG_VERSION:=4.2.8p15
|
PKG_VERSION:=4.2.8p15
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=4
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
|
PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
|
||||||
|
|
|
@ -0,0 +1,27 @@
|
||||||
|
From 082a504cfcc046c3d8adaae1164268bc94e5108a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Khem Raj <raj.khem@gmail.com>
|
||||||
|
Date: Sat, 31 Jul 2021 10:51:41 -0700
|
||||||
|
Subject: [PATCH] libntp: Do not use PTHREAD_STACK_MIN on glibc
|
||||||
|
|
||||||
|
In glibc 2.34+ PTHREAD_STACK_MIN is not a compile-time constant which
|
||||||
|
could mean different stack sizes at runtime on different architectures
|
||||||
|
and it also causes compile failure. Default glibc thread stack size
|
||||||
|
or 64Kb set by ntp should be good in glibc these days.
|
||||||
|
|
||||||
|
Upstream-Status: Pending
|
||||||
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||||
|
---
|
||||||
|
libntp/work_thread.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
--- a/libntp/work_thread.c
|
||||||
|
+++ b/libntp/work_thread.c
|
||||||
|
@@ -41,7 +41,7 @@
|
||||||
|
#ifndef THREAD_MINSTACKSIZE
|
||||||
|
# define THREAD_MINSTACKSIZE (64U * 1024)
|
||||||
|
#endif
|
||||||
|
-#ifndef __sun
|
||||||
|
+#if !defined(__sun) && !defined(__GLIBC__)
|
||||||
|
#if defined(PTHREAD_STACK_MIN) && THREAD_MINSTACKSIZE < PTHREAD_STACK_MIN
|
||||||
|
# undef THREAD_MINSTACKSIZE
|
||||||
|
# define THREAD_MINSTACKSIZE PTHREAD_STACK_MIN
|
Loading…
Reference in a new issue