Merge pull request #6349 from jefferyto/python-package-updates-openwrt-18.06
[openwrt-18.06] Python package updates
This commit is contained in:
commit
d471ad56c2
14 changed files with 80 additions and 72 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-attrs
|
||||
PKG_VERSION:=17.4.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=18.1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=attrs-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/8b/0b/a06cfcb69d0cb004fde8bc6f0fd192d96d565d1b8aa2829f0f20adb796e5
|
||||
PKG_HASH:=1c7960ccfd6a005cd9f7ba884e6316b5e430a3f1a6c37c5f87d8b43f83b54ec9
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/a/attrs
|
||||
PKG_HASH:=e0d0eb91441a3b53dab4d9b743eafc1ac44476296a2053b6ca3af0b139faf87b
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-attrs-$(PKG_VERSION)
|
||||
|
||||
|
@ -31,19 +31,19 @@ define Package/python-attrs/Default
|
|||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
SUBMENU:=Python
|
||||
URL:=https://attrs.readthedocs.org/
|
||||
URL:=http://www.attrs.org/
|
||||
endef
|
||||
|
||||
define Package/python-attrs
|
||||
$(call Package/python-attrs/Default)
|
||||
TITLE:=python-attrs
|
||||
TITLE:=Classes Without Boilerplate
|
||||
DEPENDS:=+PACKAGE_python-attrs:python-light
|
||||
VARIANT:=python
|
||||
endef
|
||||
|
||||
define Package/python3-attrs
|
||||
$(call Package/python-attrs/Default)
|
||||
TITLE:=python3-attrs
|
||||
TITLE:=Classes Without Boilerplate
|
||||
DEPENDS:=+PACKAGE_python3-attrs:python3-light
|
||||
VARIANT:=python3
|
||||
endef
|
||||
|
|
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-automat
|
||||
PKG_VERSION:=0.6.0
|
||||
PKG_VERSION:=0.7.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=Automat-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/A/Automat
|
||||
PKG_HASH:=3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8
|
||||
PKG_HASH:=cbd78b83fa2d81fe2a4d23d258e1661dd7493c9a50ee2f1a5b2cac61c1793b0e
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-automat-$(PKG_VERSION)
|
||||
|
||||
|
|
|
@ -26,5 +26,5 @@
|
|||
- 'm2r',
|
||||
- ],
|
||||
install_requires=[
|
||||
"attrs",
|
||||
"attrs>=16.1.0",
|
||||
"six",
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -27,15 +27,6 @@ setup(
|
||||
"attrs",
|
||||
"attrs>=16.1.0",
|
||||
"six",
|
||||
],
|
||||
- extras_require={
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
+ packages=find_packages(exclude=["*._test", "*._test.*"]),
|
||||
package_dir={'automat': 'automat'},
|
||||
install_requires=[
|
||||
"attrs",
|
||||
"attrs>=16.1.0",
|
||||
@@ -30,6 +30,7 @@ setup(
|
||||
author='Glyph',
|
||||
author_email='glyph@twistedmatrix.com',
|
||||
|
@ -16,4 +16,4 @@
|
|||
+ exclude_package_data={'':['_test/*']},
|
||||
license="MIT",
|
||||
keywords='fsm finite state machine automata',
|
||||
)
|
||||
classifiers=[
|
||||
|
|
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-hyperlink
|
||||
PKG_VERSION:=17.3.1
|
||||
PKG_VERSION:=18.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=hyperlink-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/h/hyperlink
|
||||
PKG_HASH:=bc4ffdbde9bdad204d507bd8f554f16bba82dd356f6130cb16f41422909c33bc
|
||||
PKG_HASH:=f01b4ff744f14bc5d0a22a6b9f1525ab7d6312cb0ff967f59414bbac52f0a306
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-hyperlink-$(PKG_VERSION)
|
||||
|
||||
|
@ -37,14 +37,18 @@ endef
|
|||
define Package/python-hyperlink
|
||||
$(call Package/python-hyperlink/Default)
|
||||
TITLE:=Pure-Python immutable URLs
|
||||
DEPENDS:=+PACKAGE_python-hyperlink:python-light
|
||||
DEPENDS:= \
|
||||
+PACKAGE_python-hyperlink:python-light \
|
||||
+PACKAGE_python-hyperlink:python-idna
|
||||
VARIANT:=python
|
||||
endef
|
||||
|
||||
define Package/python3-hyperlink
|
||||
$(call Package/python-hyperlink/Default)
|
||||
TITLE:=Pure-Python immutable URLs
|
||||
DEPENDS:=+PACKAGE_python3-hyperlink:python3-light
|
||||
DEPENDS:= \
|
||||
+PACKAGE_python3-hyperlink:python3-light \
|
||||
+PACKAGE_python3-hyperlink:python3-idna
|
||||
VARIANT:=python3
|
||||
endef
|
||||
|
||||
|
|
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-ipaddress
|
||||
PKG_VERSION:=1.0.19
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.0.22
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=ipaddress-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/f0/ba/860a4a3e283456d6b7e2ab39ce5cf11a3490ee1a363652ac50abf9f0f5df
|
||||
PKG_HASH:=200d8686011d470b5e4de207d803445deee427455cd0cb7c982b68cf82524f81
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/i/ipaddress
|
||||
PKG_HASH:=b146c751ea45cad6188dd6cf2d9b757f6f4f8d6ffb96a023e6f2e26eea02a72c
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-ipaddress-$(PKG_VERSION)
|
||||
|
||||
|
@ -34,7 +34,7 @@ endef
|
|||
|
||||
define Package/python-ipaddress
|
||||
$(call Package/python-ipaddress/Default)
|
||||
TITLE:=python-ipaddress
|
||||
TITLE:=Python 3.3+'s ipaddress
|
||||
DEPENDS:=+PACKAGE_python-ipaddress:python-light
|
||||
VARIANT:=python
|
||||
endef
|
||||
|
|
|
@ -8,12 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-ply
|
||||
PKG_VERSION:=3.10
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=3.11
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=ply-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.dabeaz.com/ply
|
||||
PKG_HASH:=96e94af7dd7031d8d6dd6e2a8e0de593b511c211a86e28a9c9621c275ac8bacb
|
||||
PKG_SOURCE_URL:=http://www.dabeaz.com/ply \
|
||||
https://files.pythonhosted.org/packages/source/p/ply
|
||||
PKG_HASH:=00c7c1aaa88358b9c765b6d3000c6eec0ba42abca5351b095321aef446081da3
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-ply-$(PKG_VERSION)
|
||||
|
||||
|
@ -36,14 +37,14 @@ endef
|
|||
|
||||
define Package/python-ply
|
||||
$(call Package/python-ply/Default)
|
||||
TITLE:=python-ply
|
||||
TITLE:=lex and yacc for Python
|
||||
DEPENDS:=+PACKAGE_python-ply:python-light
|
||||
VARIANT:=python
|
||||
endef
|
||||
|
||||
define Package/python3-ply
|
||||
$(call Package/python-ply/Default)
|
||||
TITLE:=python3-ply
|
||||
TITLE:=lex and yacc for Python
|
||||
DEPENDS:=+PACKAGE_python3-ply:python3-light
|
||||
VARIANT:=python3
|
||||
endef
|
||||
|
|
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-pyasn1
|
||||
PKG_VERSION:=0.4.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.4.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=pyasn1-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/eb/3d/b7d0fdf4a882e26674c68c20f40682491377c4db1439870f5b6f862f76ed
|
||||
PKG_HASH:=d258b0a71994f7770599835249cece1caef3c70def868c4915e6e5ca49b67d15
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/p/pyasn1
|
||||
PKG_HASH:=fb81622d8f3509f0026b0683fe90fea27be7284d3826a5f2edf97f69151ab0fc
|
||||
|
||||
PKG_LICENSE:=BSD-2-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE.txt
|
||||
|
@ -31,19 +31,19 @@ define Package/python-pyasn1/Default
|
|||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
SUBMENU:=Python
|
||||
URL:=http://pyasn1.sourceforge.net/
|
||||
URL:=https://github.com/etingof/pyasn1
|
||||
endef
|
||||
|
||||
define Package/python-pyasn1
|
||||
$(call Package/python-pyasn1/Default)
|
||||
TITLE:=python-pyasn1
|
||||
TITLE:=ASN.1 library for Python
|
||||
DEPENDS:=+PACKAGE_python-pyasn1:python-light
|
||||
VARIANT:=python
|
||||
endef
|
||||
|
||||
define Package/python3-pyasn1
|
||||
$(call Package/python-pyasn1/Default)
|
||||
TITLE:=python3-pyasn1
|
||||
TITLE:=ASN.1 library for Python
|
||||
DEPENDS:=+PACKAGE_python3-pyasn1:python3-light
|
||||
VARIANT:=python3
|
||||
endef
|
||||
|
|
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-zope-interface
|
||||
PKG_VERSION:=4.4.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=4.5.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=zope.interface-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/bd/d2/25349ed41f9dcff7b3baf87bd88a4c82396cf6e02f1f42bb68657a3132af
|
||||
PKG_HASH:=d6d26d5dfbfd60c65152938fcb82f949e8dada37c041f72916fef6621ba5c5ce
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/z/zope.interface
|
||||
PKG_HASH:=57c38470d9f57e37afb460c399eb254e7193ac7fb8042bd09bdc001981a9c74c
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-zope-interface-$(PKG_VERSION)
|
||||
|
||||
|
@ -36,14 +36,14 @@ endef
|
|||
|
||||
define Package/python-zope-interface
|
||||
$(call Package/python-zope-interface/Default)
|
||||
TITLE:=python-zope-interface
|
||||
TITLE:=Interfaces for Python
|
||||
DEPENDS:=+PACKAGE_python-zope-interface:python-light
|
||||
VARIANT:=python
|
||||
endef
|
||||
|
||||
define Package/python3-zope-interface
|
||||
$(call Package/python-zope-interface/Default)
|
||||
TITLE:=python3-zope-interface
|
||||
TITLE:=Interfaces for Python
|
||||
DEPENDS:=+PACKAGE_python3-zope-interface:python3-light
|
||||
VARIANT:=python3
|
||||
endef
|
||||
|
@ -61,18 +61,6 @@ $(call Package/python-zope-interface/description)
|
|||
(Variant for Python3)
|
||||
endef
|
||||
|
||||
define PyPackage/python-zope-interface/filespec
|
||||
+|$(PYTHON_PKG_DIR)
|
||||
-|$(PYTHON_PKG_DIR)/zope/interface/common/tests
|
||||
-|$(PYTHON_PKG_DIR)/zope/interface/tests
|
||||
endef
|
||||
|
||||
define Py3Package/python3-zope-interface/filespec
|
||||
+|$(PYTHON3_PKG_DIR)
|
||||
-|$(PYTHON3_PKG_DIR)/zope/interface/common/tests
|
||||
-|$(PYTHON3_PKG_DIR)/zope/interface/tests
|
||||
endef
|
||||
|
||||
$(eval $(call PyPackage,python-zope-interface))
|
||||
$(eval $(call BuildPackage,python-zope-interface))
|
||||
$(eval $(call BuildPackage,python-zope-interface-src))
|
||||
|
|
|
@ -0,0 +1,21 @@
|
|||
diff --git a/setup.py b/setup.py
|
||||
index 0eb36ea..2e64aae 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -121,7 +121,7 @@ setup(name='zope.interface',
|
||||
"Framework :: Zope3",
|
||||
"Topic :: Software Development :: Libraries :: Python Modules",
|
||||
],
|
||||
- packages=find_packages('src'),
|
||||
+ packages=find_packages('src', exclude=["*.tests", "*.tests.*"]),
|
||||
package_dir={'': 'src'},
|
||||
namespace_packages=["zope"],
|
||||
cmdclass={
|
||||
@@ -129,6 +129,7 @@ setup(name='zope.interface',
|
||||
},
|
||||
test_suite='zope.interface.tests',
|
||||
include_package_data=True,
|
||||
+ exclude_package_data={'':['tests/*']},
|
||||
zip_safe=False,
|
||||
tests_require=tests_require,
|
||||
install_requires=['setuptools'],
|
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=twisted
|
||||
PKG_VERSION:=17.9.0
|
||||
PKG_VERSION:=18.4.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=Twisted-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/T/Twisted
|
||||
PKG_HASH:=0da1a7e35d5fcae37bc9c7978970b5feb3bc82822155b8654ec63925c05af75c
|
||||
PKG_HASH:=a4cc164a781859c74de47f17f0e85f4bce8a3321a9d0892c015c8f80c4158ad9
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-twisted-$(PKG_VERSION)
|
||||
PKG_BUILD_DEPENDS:=USE_MUSL:librpc
|
||||
|
|
|
@ -1,22 +1,18 @@
|
|||
diff --git a/src/twisted/python/_setup.py b/src/twisted/python/_setup.py
|
||||
index 3b5f69d4b..c69c5d13c 100644
|
||||
--- a/src/twisted/python/_setup.py
|
||||
+++ b/src/twisted/python/_setup.py
|
||||
@@ -142,7 +142,6 @@ _CONSOLE_SCRIPTS = [
|
||||
"cftp = twisted.conch.scripts.cftp:run",
|
||||
@@ -143,7 +143,6 @@ _CONSOLE_SCRIPTS = [
|
||||
"conch = twisted.conch.scripts.conch:run",
|
||||
"mailmail = twisted.mail.scripts.mailmail:run",
|
||||
"pyhtmlizer = twisted.scripts.htmlizer:run",
|
||||
- "tkconch = twisted.conch.scripts.tkconch:run",
|
||||
"trial = twisted.scripts.trial:run",
|
||||
"twist = twisted.application.twist._twist:Twist.main",
|
||||
"twistd = twisted.scripts.twistd:run",
|
||||
diff --git a/src/twisted/python/twisted-completion.zsh b/src/twisted/python/twisted-completion.zsh
|
||||
index 4d97aa5d3..9a8d4d82e 100644
|
||||
--- a/src/twisted/python/twisted-completion.zsh
|
||||
+++ b/src/twisted/python/twisted-completion.zsh
|
||||
@@ -1,4 +1,4 @@
|
||||
-#compdef twistd trial conch cftp ckeygen pyhtmlizer tkconch
|
||||
+#compdef twistd trial conch cftp ckeygen pyhtmlizer
|
||||
-#compdef twist twistd trial conch cftp ckeygen pyhtmlizer tkconch
|
||||
+#compdef twist twistd trial conch cftp ckeygen pyhtmlizer
|
||||
#
|
||||
# This is the ZSH completion file for Twisted commands. It calls the current
|
||||
# command-line with the special "--_shell-completion" option which is handled
|
|
@ -1,21 +1,19 @@
|
|||
diff --git a/src/twisted/python/_setup.py b/src/twisted/python/_setup.py
|
||||
index 3b5f69d4b..2dca47aa5 100644
|
||||
--- a/src/twisted/python/_setup.py
|
||||
+++ b/src/twisted/python/_setup.py
|
||||
@@ -175,11 +175,6 @@ class ConditionalExtension(Extension, object):
|
||||
|
||||
@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, ob
|
||||
# The C extensions used for Twisted.
|
||||
_EXTENSIONS = [
|
||||
- ConditionalExtension(
|
||||
ConditionalExtension(
|
||||
- "twisted.test.raiser",
|
||||
- sources=["src/twisted/test/raiser.c"],
|
||||
- condition=lambda _: _isCPython),
|
||||
-
|
||||
ConditionalExtension(
|
||||
- ConditionalExtension(
|
||||
"twisted.internet.iocpreactor.iocpsupport",
|
||||
sources=[
|
||||
@@ -232,7 +227,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
|
||||
requirements.append("hyperlink >= 17.1.1")
|
||||
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
|
||||
@@ -240,7 +235,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
||||
]
|
||||
|
||||
arguments.update(dict(
|
||||
- packages=find_packages("src"),
|
||||
|
@ -23,7 +21,7 @@ index 3b5f69d4b..2dca47aa5 100644
|
|||
use_incremental=True,
|
||||
setup_requires=["incremental >= 16.10.1"],
|
||||
install_requires=requirements,
|
||||
@@ -241,6 +236,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
|
||||
@@ -249,6 +244,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
||||
},
|
||||
cmdclass=command_classes,
|
||||
include_package_data=True,
|
||||
|
|
Loading…
Reference in a new issue