commit
d4039aac6c
3 changed files with 7 additions and 31 deletions
|
@ -9,15 +9,13 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=bridge-utils
|
||||
PKG_VERSION:=1.5
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=1.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git
|
||||
PKG_SOURCE_VERSION:=v${PKG_VERSION}
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MIRROR_HASH:=ce568c41f60987ed972c53fb8dab92bf45052849c4992e8ae931c1eb505630b7
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/$(PKG_NAME)
|
||||
PKG_HASH:=cc67efb5d5fb8928a6569b3fade2b4042ec17da04678dab127d96b46489e26c8
|
||||
PKG_MAINTAINER:=Nikolay Martynov <mar.kolya@gmail.com>
|
||||
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -29,8 +27,7 @@ define Package/bridge
|
|||
SECTION:=net
|
||||
CATEGORY:=Base system
|
||||
TITLE:=Ethernet bridging configuration utility
|
||||
URL:=http://bridge.sourceforge.net/
|
||||
PKG_MAINTAINER:=Nikolay Martynov <mar.kolya@gmail.com>
|
||||
URL:=http://www.linuxfromscratch.org/blfs/view/svn/basicnet/bridge-utils.html
|
||||
endef
|
||||
|
||||
define Package/bridge/description
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- a/libbridge/libbridge.h
|
||||
+++ b/libbridge/libbridge.h
|
||||
@@ -20,6 +20,7 @@
|
||||
#define _LIBBRIDGE_H
|
||||
|
||||
#include <sys/socket.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <linux/if.h>
|
||||
#include <linux/if_bridge.h>
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- a/libbridge/libbridge.h
|
||||
+++ b/libbridge/libbridge.h
|
||||
@@ -19,6 +19,8 @@
|
||||
#ifndef _LIBBRIDGE_H
|
||||
#define _LIBBRIDGE_H
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/select.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netinet/in.h>
|
||||
#include <linux/if.h>
|
Loading…
Reference in a new issue