forked-daapd: fix compilation with GCC10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
3331857824
commit
d198307fd4
2 changed files with 21 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=forked-daapd
|
||||
PKG_VERSION:=27.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/
|
||||
|
|
20
sound/forked-daapd/patches/020-gcc10.patch
Normal file
20
sound/forked-daapd/patches/020-gcc10.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- a/src/outputs.h
|
||||
+++ b/src/outputs.h
|
||||
@@ -185,7 +185,7 @@ struct output_data
|
||||
int samples;
|
||||
};
|
||||
|
||||
-struct output_buffer
|
||||
+static struct output_buffer
|
||||
{
|
||||
struct timespec pts;
|
||||
// The array is two larger than max quality subscriptions because element 0
|
||||
@@ -262,7 +262,7 @@ struct output_definition
|
||||
};
|
||||
|
||||
// Our main list of devices, not for use by backend modules
|
||||
-struct output_device *output_device_list;
|
||||
+static struct output_device *output_device_list;
|
||||
|
||||
/* ------------------------------- General use ------------------------------ */
|
||||
|
Loading…
Reference in a new issue