motion: Update to 4.1.1 and switch to codeload
Simpler. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
668b1abbbf
commit
d0e2f0b7ce
2 changed files with 8 additions and 59 deletions
|
@ -8,22 +8,20 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=motion
|
PKG_NAME:=motion
|
||||||
PKG_VERSION=3.4.0-20141018-$(PKG_SOURCE_VERSION)
|
PKG_VERSION:=4.1.1
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
||||||
PKG_LICENSE:=GPLv2
|
PKG_LICENSE:=GPLv2
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE:=$(PKG_NAME)-release-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/Mr-Dave/motion.git
|
PKG_SOURCE_URL:=https://codeload.github.com/Motion-Project/motion/tar.gz/release-$(PKG_VERSION)?
|
||||||
PKG_SOURCE_VERSION:=9479d910f2149b5558788bb86f97f26522794212
|
PKG_HASH:=2074b935bdfe28f84c2c3233274b06908336778f303bb13530d4299c3f8aa4e2
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-release-$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
|
|
||||||
PKG_MIRROR_HASH:=02602c775ec3829dac59aed16ea6b0d78f77a435b9c360db1a05cb27227da97e
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
PKG_FIXUP:=autoreconf
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -32,7 +30,7 @@ define Package/motion
|
||||||
CATEGORY:=Multimedia
|
CATEGORY:=Multimedia
|
||||||
DEPENDS:=+libjpeg +libpthread
|
DEPENDS:=+libjpeg +libpthread
|
||||||
TITLE:=webcam motion sensing and logging
|
TITLE:=webcam motion sensing and logging
|
||||||
URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
|
URL:=https://motion-project.github.io/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/motion/conffiles
|
define Package/motion/conffiles
|
||||||
|
|
|
@ -1,49 +0,0 @@
|
||||||
--- a/motion.c
|
|
||||||
+++ b/motion.c
|
|
||||||
@@ -2630,6 +2630,17 @@ int main (int argc, char **argv)
|
|
||||||
struct sigaction sigchild_action;
|
|
||||||
setup_signals(&sig_handler_action, &sigchild_action);
|
|
||||||
|
|
||||||
+ /*
|
|
||||||
+ * Create and a thread attribute for the threads we spawn later on.
|
|
||||||
+ * PTHREAD_CREATE_DETACHED means to create threads detached, i.e.
|
|
||||||
+ * their termination cannot be synchronized through 'pthread_join'.
|
|
||||||
+ */
|
|
||||||
+ pthread_attr_init(&thread_attr);
|
|
||||||
+ pthread_attr_setdetachstate(&thread_attr, PTHREAD_CREATE_DETACHED);
|
|
||||||
+
|
|
||||||
+ /* Create the TLS key for thread number. */
|
|
||||||
+ pthread_key_create(&tls_key_threadnr, NULL);
|
|
||||||
+
|
|
||||||
motion_startup(1, argc, argv);
|
|
||||||
|
|
||||||
#ifdef HAVE_FFMPEG
|
|
||||||
@@ -2648,17 +2659,6 @@ int main (int argc, char **argv)
|
|
||||||
if (cnt_list[0]->conf.setup_mode)
|
|
||||||
MOTION_LOG(NTC, TYPE_ALL, NO_ERRNO, "%s: Motion running in setup mode.");
|
|
||||||
|
|
||||||
- /*
|
|
||||||
- * Create and a thread attribute for the threads we spawn later on.
|
|
||||||
- * PTHREAD_CREATE_DETACHED means to create threads detached, i.e.
|
|
||||||
- * their termination cannot be synchronized through 'pthread_join'.
|
|
||||||
- */
|
|
||||||
- pthread_attr_init(&thread_attr);
|
|
||||||
- pthread_attr_setdetachstate(&thread_attr, PTHREAD_CREATE_DETACHED);
|
|
||||||
-
|
|
||||||
- /* Create the TLS key for thread number. */
|
|
||||||
- pthread_key_create(&tls_key_threadnr, NULL);
|
|
||||||
-
|
|
||||||
do {
|
|
||||||
if (restart) {
|
|
||||||
/*
|
|
||||||
--- a/motion.h
|
|
||||||
+++ b/motion.h
|
|
||||||
@@ -84,7 +84,7 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
/* strerror_r() XSI vs GNU */
|
|
||||||
-#if (defined(BSD)) || ((_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && ! _GNU_SOURCE)
|
|
||||||
+#if (defined(BSD)) || ((_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && ! _GNU_SOURCE) || (!defined(__GLIBC__))
|
|
||||||
#define XSI_STRERROR_R
|
|
||||||
#endif
|
|
||||||
|
|
Loading…
Reference in a new issue