Merge pull request #11232 from neheb/lswan

libreswan: fix compilation with musl
This commit is contained in:
Rosen Penev 2020-02-04 13:02:41 -08:00 committed by GitHub
commit d00f2c9a40
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 21 additions and 1 deletions

View file

@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libreswan
PKG_VERSION:=3.29
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.libreswan.org/

View file

@ -0,0 +1,20 @@
--- a/programs/pluto/connections.c
+++ b/programs/pluto/connections.c
@@ -34,6 +34,7 @@
#include <stdio.h>
#include <stddef.h>
#include <stdlib.h>
+#include <limits.h>
#include <unistd.h>
#include <netinet/in.h>
#include <sys/socket.h>
--- a/programs/pluto/rcv_whack.c
+++ b/programs/pluto/rcv_whack.c
@@ -36,6 +36,7 @@
#include <resolv.h>
#include <fcntl.h>
#include <unistd.h> /* for gethostname() */
+#include <limits.h>
#include <libreswan.h>
#include "libreswan/pfkeyv2.h"