php7: update to 7.2.5
Also drop obsolete patches. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
19ba0551a8
commit
d0057d5eb4
4 changed files with 4 additions and 658 deletions
|
@ -6,7 +6,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=php
|
||||
PKG_VERSION:=7.2.4
|
||||
PKG_VERSION:=7.2.5
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
||||
|
@ -16,7 +16,7 @@ PKG_LICENSE_FILES:=LICENSE
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
||||
PKG_HASH:=7916b1bd148ddfd46d7f8f9a517d4b09cd8a8ad9248734e7c8dd91ef17057a88
|
||||
PKG_HASH:=af70a33b3f7a51510467199b39af151333fbbe4cc21923bad9c7cf64268cddb2
|
||||
|
||||
PKG_FIXUP:=libtool autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
@ -167,6 +167,7 @@ CONFIGURE_ARGS+= \
|
|||
--with-config-file-scan-dir=/etc/php7 \
|
||||
--disable-short-tags \
|
||||
\
|
||||
--without-valgrind \
|
||||
--with-pcre-regex="$(STAGING_DIR)/usr" \
|
||||
--with-zlib="$(STAGING_DIR)/usr" \
|
||||
--with-zlib-dir="$(STAGING_DIR)/usr"
|
||||
|
@ -469,8 +470,7 @@ CONFIGURE_VARS+= \
|
|||
php_cv_cc_rpath="no" \
|
||||
iconv_impl_name="gnu_libiconv" \
|
||||
ac_cv_php_xml2_config_path="$(STAGING_DIR)/host/bin/xml2-config" \
|
||||
ac_cv_u8t_decompose=yes \
|
||||
ac_cv_enable_valgrind_check=no \
|
||||
ac_cv_u8t_decompose=yes
|
||||
|
||||
define Package/php7/conffiles
|
||||
/etc/php.ini
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
--- a/acinclude.m4 2017-11-28 10:22:53.000000000 +0100
|
||||
+++ b/acinclude.m4 2017-12-22 16:28:09.361331754 +0100
|
||||
@@ -3227,20 +3227,26 @@
|
||||
|
||||
dnl PHP_CHECK_VALGRIND
|
||||
AC_DEFUN([PHP_CHECK_VALGRIND], [
|
||||
- AC_MSG_CHECKING([for valgrind])
|
||||
+ AC_CACHE_CHECK(whether to enable the check for valgrind support,ac_cv_enable_valgrind_check,[
|
||||
+ ac_cv_enable_valgrind_check=yes
|
||||
+ ])
|
||||
|
||||
- SEARCH_PATH="/usr/local /usr"
|
||||
- SEARCH_FOR="/include/valgrind/valgrind.h"
|
||||
- for i in $SEARCH_PATH ; do
|
||||
- if test -r $i/$SEARCH_FOR; then
|
||||
- VALGRIND_DIR=$i
|
||||
- fi
|
||||
- done
|
||||
+ if test "$ac_cv_enable_valgrind_check" = "yes"; then
|
||||
+ AC_MSG_CHECKING([for valgrind])
|
||||
+
|
||||
+ SEARCH_PATH="/usr/local /usr"
|
||||
+ SEARCH_FOR="/include/valgrind/valgrind.h"
|
||||
+ for i in $SEARCH_PATH ; do
|
||||
+ if test -r $i/$SEARCH_FOR; then
|
||||
+ VALGRIND_DIR=$i
|
||||
+ fi
|
||||
+ done
|
||||
|
||||
- if test -z "$VALGRIND_DIR"; then
|
||||
- AC_MSG_RESULT([not found])
|
||||
- else
|
||||
- AC_MSG_RESULT(found in $VALGRIND_DIR)
|
||||
- AC_DEFINE(HAVE_VALGRIND, 1, [ ])
|
||||
+ if test -z "$VALGRIND_DIR"; then
|
||||
+ AC_MSG_RESULT([not found])
|
||||
+ else
|
||||
+ AC_MSG_RESULT(found in $VALGRIND_DIR)
|
||||
+ AC_DEFINE(HAVE_VALGRIND, 1, [ ])
|
||||
+ fi
|
||||
fi
|
||||
])
|
|
@ -1,305 +0,0 @@
|
|||
From 8d35a423838eb462cd39ee535c5d003073cc5f22 Mon Sep 17 00:00:00 2001
|
||||
From: Anatol Belski <ab@php.net>
|
||||
Date: Sat, 31 Mar 2018 18:51:03 +0200
|
||||
Subject: [PATCH] Utilize the recommended way to handle the icu namespace
|
||||
|
||||
---
|
||||
ext/intl/breakiterator/breakiterator_class.cpp | 1 +
|
||||
ext/intl/breakiterator/breakiterator_class.h | 2 ++
|
||||
ext/intl/breakiterator/breakiterator_methods.cpp | 2 ++
|
||||
ext/intl/breakiterator/codepointiterator_internal.cpp | 2 ++
|
||||
ext/intl/breakiterator/codepointiterator_internal.h | 3 +++
|
||||
ext/intl/breakiterator/rulebasedbreakiterator_methods.cpp | 3 +++
|
||||
ext/intl/calendar/calendar_class.cpp | 3 +++
|
||||
ext/intl/calendar/calendar_class.h | 2 ++
|
||||
ext/intl/calendar/calendar_methods.cpp | 2 ++
|
||||
ext/intl/calendar/gregoriancalendar_methods.cpp | 7 +++++++
|
||||
ext/intl/common/common_date.cpp | 3 +++
|
||||
ext/intl/common/common_date.h | 2 ++
|
||||
ext/intl/common/common_enum.h | 1 +
|
||||
ext/intl/dateformat/dateformat_format_object.cpp | 6 ++++++
|
||||
ext/intl/dateformat/dateformat_helpers.cpp | 2 ++
|
||||
ext/intl/dateformat/dateformat_helpers.h | 5 +++++
|
||||
ext/intl/intl_convertcpp.h | 2 ++
|
||||
ext/intl/msgformat/msgformat_helpers.cpp | 10 ++++++++++
|
||||
ext/intl/timezone/timezone_class.cpp | 2 ++
|
||||
ext/intl/timezone/timezone_class.h | 2 ++
|
||||
ext/intl/timezone/timezone_methods.cpp | 4 ++++
|
||||
21 files changed, 66 insertions(+)
|
||||
|
||||
--- a/ext/intl/breakiterator/breakiterator_class.cpp
|
||||
+++ b/ext/intl/breakiterator/breakiterator_class.cpp
|
||||
@@ -38,6 +38,7 @@ extern "C" {
|
||||
}
|
||||
|
||||
using PHP::CodePointBreakIterator;
|
||||
+using U_ICU_NAMESPACE::RuleBasedBreakIterator;
|
||||
|
||||
/* {{{ Global variables */
|
||||
zend_class_entry *BreakIterator_ce_ptr;
|
||||
--- a/ext/intl/breakiterator/breakiterator_class.h
|
||||
+++ b/ext/intl/breakiterator/breakiterator_class.h
|
||||
@@ -26,6 +26,8 @@
|
||||
|
||||
#ifndef USE_BREAKITERATOR_POINTER
|
||||
typedef void BreakIterator;
|
||||
+#else
|
||||
+using U_ICU_NAMESPACE::BreakIterator;
|
||||
#endif
|
||||
|
||||
typedef struct {
|
||||
--- a/ext/intl/breakiterator/breakiterator_methods.cpp
|
||||
+++ b/ext/intl/breakiterator/breakiterator_methods.cpp
|
||||
@@ -32,6 +32,8 @@ extern "C" {
|
||||
}
|
||||
|
||||
using PHP::CodePointBreakIterator;
|
||||
+using U_ICU_NAMESPACE::BreakIterator;
|
||||
+using U_ICU_NAMESPACE::Locale;
|
||||
|
||||
U_CFUNC PHP_METHOD(BreakIterator, __construct)
|
||||
{
|
||||
--- a/ext/intl/breakiterator/codepointiterator_internal.cpp
|
||||
+++ b/ext/intl/breakiterator/codepointiterator_internal.cpp
|
||||
@@ -33,6 +33,8 @@ typedef union {
|
||||
|
||||
using namespace PHP;
|
||||
|
||||
+using U_ICU_NAMESPACE::UCharCharacterIterator;
|
||||
+
|
||||
UOBJECT_DEFINE_RTTI_IMPLEMENTATION(CodePointBreakIterator);
|
||||
|
||||
CodePointBreakIterator::CodePointBreakIterator()
|
||||
--- a/ext/intl/breakiterator/codepointiterator_internal.h
|
||||
+++ b/ext/intl/breakiterator/codepointiterator_internal.h
|
||||
@@ -18,8 +18,11 @@
|
||||
#define CODEPOINTITERATOR_INTERNAL_H
|
||||
|
||||
#include <unicode/brkiter.h>
|
||||
+#include <unicode/unistr.h>
|
||||
|
||||
using U_ICU_NAMESPACE::BreakIterator;
|
||||
+using U_ICU_NAMESPACE::CharacterIterator;
|
||||
+using U_ICU_NAMESPACE::UnicodeString;
|
||||
|
||||
namespace PHP {
|
||||
|
||||
--- a/ext/intl/breakiterator/rulebasedbreakiterator_methods.cpp
|
||||
+++ b/ext/intl/breakiterator/rulebasedbreakiterator_methods.cpp
|
||||
@@ -26,6 +26,9 @@ extern "C" {
|
||||
#include "../intl_convertcpp.h"
|
||||
#include "../intl_common.h"
|
||||
|
||||
+using U_ICU_NAMESPACE::RuleBasedBreakIterator;
|
||||
+using U_ICU_NAMESPACE::Locale;
|
||||
+
|
||||
static inline RuleBasedBreakIterator *fetch_rbbi(BreakIterator_object *bio) {
|
||||
return (RuleBasedBreakIterator*)bio->biter;
|
||||
}
|
||||
--- a/ext/intl/calendar/calendar_class.cpp
|
||||
+++ b/ext/intl/calendar/calendar_class.cpp
|
||||
@@ -34,6 +34,9 @@ extern "C" {
|
||||
#include <assert.h>
|
||||
}
|
||||
|
||||
+using U_ICU_NAMESPACE::GregorianCalendar;
|
||||
+using U_ICU_NAMESPACE::Locale;
|
||||
+
|
||||
/* {{{ Global variables */
|
||||
zend_class_entry *Calendar_ce_ptr;
|
||||
zend_class_entry *GregorianCalendar_ce_ptr;
|
||||
--- a/ext/intl/calendar/calendar_class.h
|
||||
+++ b/ext/intl/calendar/calendar_class.h
|
||||
@@ -26,6 +26,8 @@
|
||||
|
||||
#ifndef USE_CALENDAR_POINTER
|
||||
typedef void Calendar;
|
||||
+#else
|
||||
+using U_ICU_NAMESPACE::Calendar;
|
||||
#endif
|
||||
|
||||
typedef struct {
|
||||
--- a/ext/intl/calendar/calendar_methods.cpp
|
||||
+++ b/ext/intl/calendar/calendar_methods.cpp
|
||||
@@ -40,6 +40,8 @@ extern "C" {
|
||||
}
|
||||
#include "../common/common_enum.h"
|
||||
|
||||
+using U_ICU_NAMESPACE::Locale;
|
||||
+
|
||||
U_CFUNC PHP_METHOD(IntlCalendar, __construct)
|
||||
{
|
||||
zend_throw_exception( NULL,
|
||||
--- a/ext/intl/calendar/gregoriancalendar_methods.cpp
|
||||
+++ b/ext/intl/calendar/gregoriancalendar_methods.cpp
|
||||
@@ -23,6 +23,8 @@
|
||||
#include <unicode/locid.h>
|
||||
#include <unicode/calendar.h>
|
||||
#include <unicode/gregocal.h>
|
||||
+#include <unicode/ustring.h>
|
||||
+
|
||||
extern "C" {
|
||||
#include "../php_intl.h"
|
||||
#include "../intl_common.h"
|
||||
@@ -34,6 +36,11 @@ extern "C" {
|
||||
#include "zend_exceptions.h"
|
||||
}
|
||||
|
||||
+using U_ICU_NAMESPACE::GregorianCalendar;
|
||||
+using U_ICU_NAMESPACE::Locale;
|
||||
+using U_ICU_NAMESPACE::UnicodeString;
|
||||
+using U_ICU_NAMESPACE::StringPiece;
|
||||
+
|
||||
static inline GregorianCalendar *fetch_greg(Calendar_object *co) {
|
||||
return (GregorianCalendar*)co->ucal;
|
||||
}
|
||||
--- a/ext/intl/common/common_date.cpp
|
||||
+++ b/ext/intl/common/common_date.cpp
|
||||
@@ -25,6 +25,9 @@ extern "C" {
|
||||
#include <ext/date/php_date.h>
|
||||
}
|
||||
|
||||
+using U_ICU_NAMESPACE::TimeZone;
|
||||
+using U_ICU_NAMESPACE::UnicodeString;
|
||||
+
|
||||
#include "zend_portability.h"
|
||||
|
||||
/* {{{ timezone_convert_datetimezone
|
||||
--- a/ext/intl/common/common_date.h
|
||||
+++ b/ext/intl/common/common_date.h
|
||||
@@ -28,6 +28,8 @@ U_CDECL_END
|
||||
|
||||
#include <unicode/timezone.h>
|
||||
|
||||
+using U_ICU_NAMESPACE::TimeZone;
|
||||
+
|
||||
U_CFUNC TimeZone *timezone_convert_datetimezone(int type, void *object, int is_datetime, intl_error *outside_error, const char *func);
|
||||
U_CFUNC int intl_datetime_decompose(zval *z, double *millis, TimeZone **tz,
|
||||
intl_error *err, const char *func);
|
||||
--- a/ext/intl/common/common_enum.h
|
||||
+++ b/ext/intl/common/common_enum.h
|
||||
@@ -75,6 +75,7 @@ U_CFUNC zval *zoi_with_current_get_curre
|
||||
U_CFUNC void zoi_with_current_invalidate_current(zend_object_iterator *iter);
|
||||
|
||||
#ifdef __cplusplus
|
||||
+using U_ICU_NAMESPACE::StringEnumeration;
|
||||
U_CFUNC void IntlIterator_from_StringEnumeration(StringEnumeration *se, zval *object);
|
||||
#endif
|
||||
|
||||
--- a/ext/intl/dateformat/dateformat_format_object.cpp
|
||||
+++ b/ext/intl/dateformat/dateformat_format_object.cpp
|
||||
@@ -33,6 +33,12 @@ extern "C" {
|
||||
#include "../common/common_date.h"
|
||||
}
|
||||
|
||||
+using U_ICU_NAMESPACE::Locale;
|
||||
+using U_ICU_NAMESPACE::DateFormat;
|
||||
+using U_ICU_NAMESPACE::GregorianCalendar;
|
||||
+using U_ICU_NAMESPACE::StringPiece;
|
||||
+using U_ICU_NAMESPACE::SimpleDateFormat;
|
||||
+
|
||||
static const DateFormat::EStyle valid_styles[] = {
|
||||
DateFormat::kNone,
|
||||
DateFormat::kFull,
|
||||
--- a/ext/intl/dateformat/dateformat_helpers.cpp
|
||||
+++ b/ext/intl/dateformat/dateformat_helpers.cpp
|
||||
@@ -28,6 +28,8 @@ extern "C" {
|
||||
#include "../calendar/calendar_class.h"
|
||||
}
|
||||
|
||||
+using U_ICU_NAMESPACE::GregorianCalendar;
|
||||
+
|
||||
int datefmt_process_calendar_arg(zval* calendar_zv,
|
||||
Locale const& locale,
|
||||
const char *func_name,
|
||||
--- a/ext/intl/dateformat/dateformat_helpers.h
|
||||
+++ b/ext/intl/dateformat/dateformat_helpers.h
|
||||
@@ -22,11 +22,16 @@
|
||||
#endif
|
||||
|
||||
#include <unicode/calendar.h>
|
||||
+#include <unicode/datefmt.h>
|
||||
|
||||
extern "C" {
|
||||
#include "../php_intl.h"
|
||||
}
|
||||
|
||||
+using U_ICU_NAMESPACE::Locale;
|
||||
+using U_ICU_NAMESPACE::Calendar;
|
||||
+using U_ICU_NAMESPACE::DateFormat;
|
||||
+
|
||||
int datefmt_process_calendar_arg(zval* calendar_zv,
|
||||
Locale const& locale,
|
||||
const char *func_name,
|
||||
--- a/ext/intl/intl_convertcpp.h
|
||||
+++ b/ext/intl/intl_convertcpp.h
|
||||
@@ -26,6 +26,8 @@
|
||||
#include <unicode/unistr.h>
|
||||
#include <zend_types.h>
|
||||
|
||||
+using U_ICU_NAMESPACE::UnicodeString;
|
||||
+
|
||||
int intl_stringFromChar(UnicodeString &ret, char *str, size_t str_len, UErrorCode *status);
|
||||
|
||||
zend_string* intl_charFromString(const UnicodeString &from, UErrorCode *status);
|
||||
--- a/ext/intl/msgformat/msgformat_helpers.cpp
|
||||
+++ b/ext/intl/msgformat/msgformat_helpers.cpp
|
||||
@@ -76,6 +76,16 @@ MessageFormatAdapter::getMessagePattern(
|
||||
#endif
|
||||
U_NAMESPACE_END
|
||||
|
||||
+using U_ICU_NAMESPACE::Formattable;
|
||||
+using U_ICU_NAMESPACE::Format;
|
||||
+using U_ICU_NAMESPACE::DateFormat;
|
||||
+using U_ICU_NAMESPACE::MessageFormat;
|
||||
+#ifdef HAS_MESSAGE_PATTERN
|
||||
+using U_ICU_NAMESPACE::MessagePattern;
|
||||
+#endif
|
||||
+using U_ICU_NAMESPACE::MessageFormatAdapter;
|
||||
+using U_ICU_NAMESPACE::FieldPosition;
|
||||
+
|
||||
U_CFUNC int32_t umsg_format_arg_count(UMessageFormat *fmt)
|
||||
{
|
||||
int32_t fmt_count = 0;
|
||||
--- a/ext/intl/timezone/timezone_class.cpp
|
||||
+++ b/ext/intl/timezone/timezone_class.cpp
|
||||
@@ -37,6 +37,8 @@ extern "C" {
|
||||
#include <ext/date/php_date.h>
|
||||
}
|
||||
|
||||
+using U_ICU_NAMESPACE::Calendar;
|
||||
+
|
||||
/* {{{ Global variables */
|
||||
U_CDECL_BEGIN
|
||||
zend_class_entry *TimeZone_ce_ptr = NULL;
|
||||
--- a/ext/intl/timezone/timezone_class.h
|
||||
+++ b/ext/intl/timezone/timezone_class.h
|
||||
@@ -29,6 +29,8 @@
|
||||
|
||||
#ifndef USE_TIMEZONE_POINTER
|
||||
typedef void TimeZone;
|
||||
+#else
|
||||
+using U_ICU_NAMESPACE::TimeZone;
|
||||
#endif
|
||||
|
||||
typedef struct {
|
||||
--- a/ext/intl/timezone/timezone_methods.cpp
|
||||
+++ b/ext/intl/timezone/timezone_methods.cpp
|
||||
@@ -23,6 +23,7 @@
|
||||
#include <unicode/locid.h>
|
||||
#include <unicode/timezone.h>
|
||||
#include <unicode/ustring.h>
|
||||
+#include <unicode/calendar.h>
|
||||
#include "intl_convertcpp.h"
|
||||
|
||||
#include "../common/common_date.h"
|
||||
@@ -37,6 +38,9 @@ extern "C" {
|
||||
}
|
||||
#include "common/common_enum.h"
|
||||
|
||||
+using U_ICU_NAMESPACE::Locale;
|
||||
+using U_ICU_NAMESPACE::Calendar;
|
||||
+
|
||||
U_CFUNC PHP_METHOD(IntlTimeZone, __construct)
|
||||
{
|
||||
zend_throw_exception( NULL,
|
|
@ -1,307 +0,0 @@
|
|||
From d8200e48857aeaf09f7127751efc5632ef7660a7 Mon Sep 17 00:00:00 2001
|
||||
From: Anatol Belski <ab@php.net>
|
||||
Date: Sun, 1 Apr 2018 01:03:40 +0200
|
||||
Subject: [PATCH] Simplify namespace access
|
||||
|
||||
The icu namespace is an alias which resolves to the real namespace.
|
||||
---
|
||||
ext/intl/breakiterator/breakiterator_class.cpp | 2 +-
|
||||
ext/intl/breakiterator/breakiterator_class.h | 2 +-
|
||||
ext/intl/breakiterator/breakiterator_methods.cpp | 4 ++--
|
||||
ext/intl/breakiterator/codepointiterator_internal.cpp | 2 +-
|
||||
ext/intl/breakiterator/codepointiterator_internal.h | 6 +++---
|
||||
ext/intl/breakiterator/rulebasedbreakiterator_methods.cpp | 4 ++--
|
||||
ext/intl/calendar/calendar_class.cpp | 4 ++--
|
||||
ext/intl/calendar/calendar_class.h | 2 +-
|
||||
ext/intl/calendar/calendar_methods.cpp | 2 +-
|
||||
ext/intl/calendar/gregoriancalendar_methods.cpp | 8 ++++----
|
||||
ext/intl/common/common_date.cpp | 4 ++--
|
||||
ext/intl/common/common_date.h | 2 +-
|
||||
ext/intl/common/common_enum.h | 2 +-
|
||||
ext/intl/dateformat/dateformat_format_object.cpp | 10 +++++-----
|
||||
ext/intl/dateformat/dateformat_helpers.cpp | 2 +-
|
||||
ext/intl/dateformat/dateformat_helpers.h | 6 +++---
|
||||
ext/intl/intl_convertcpp.h | 2 +-
|
||||
ext/intl/msgformat/msgformat_helpers.cpp | 14 +++++++-------
|
||||
ext/intl/timezone/timezone_class.cpp | 2 +-
|
||||
ext/intl/timezone/timezone_class.h | 2 +-
|
||||
ext/intl/timezone/timezone_methods.cpp | 4 ++--
|
||||
21 files changed, 43 insertions(+), 43 deletions(-)
|
||||
|
||||
--- a/ext/intl/breakiterator/breakiterator_class.cpp
|
||||
+++ b/ext/intl/breakiterator/breakiterator_class.cpp
|
||||
@@ -38,7 +38,7 @@ extern "C" {
|
||||
}
|
||||
|
||||
using PHP::CodePointBreakIterator;
|
||||
-using U_ICU_NAMESPACE::RuleBasedBreakIterator;
|
||||
+using icu::RuleBasedBreakIterator;
|
||||
|
||||
/* {{{ Global variables */
|
||||
zend_class_entry *BreakIterator_ce_ptr;
|
||||
--- a/ext/intl/breakiterator/breakiterator_class.h
|
||||
+++ b/ext/intl/breakiterator/breakiterator_class.h
|
||||
@@ -27,7 +27,7 @@
|
||||
#ifndef USE_BREAKITERATOR_POINTER
|
||||
typedef void BreakIterator;
|
||||
#else
|
||||
-using U_ICU_NAMESPACE::BreakIterator;
|
||||
+using icu::BreakIterator;
|
||||
#endif
|
||||
|
||||
typedef struct {
|
||||
--- a/ext/intl/breakiterator/breakiterator_methods.cpp
|
||||
+++ b/ext/intl/breakiterator/breakiterator_methods.cpp
|
||||
@@ -32,8 +32,8 @@ extern "C" {
|
||||
}
|
||||
|
||||
using PHP::CodePointBreakIterator;
|
||||
-using U_ICU_NAMESPACE::BreakIterator;
|
||||
-using U_ICU_NAMESPACE::Locale;
|
||||
+using icu::BreakIterator;
|
||||
+using icu::Locale;
|
||||
|
||||
U_CFUNC PHP_METHOD(BreakIterator, __construct)
|
||||
{
|
||||
--- a/ext/intl/breakiterator/codepointiterator_internal.cpp
|
||||
+++ b/ext/intl/breakiterator/codepointiterator_internal.cpp
|
||||
@@ -33,7 +33,7 @@ typedef union {
|
||||
|
||||
using namespace PHP;
|
||||
|
||||
-using U_ICU_NAMESPACE::UCharCharacterIterator;
|
||||
+using icu::UCharCharacterIterator;
|
||||
|
||||
UOBJECT_DEFINE_RTTI_IMPLEMENTATION(CodePointBreakIterator);
|
||||
|
||||
--- a/ext/intl/breakiterator/codepointiterator_internal.h
|
||||
+++ b/ext/intl/breakiterator/codepointiterator_internal.h
|
||||
@@ -20,9 +20,9 @@
|
||||
#include <unicode/brkiter.h>
|
||||
#include <unicode/unistr.h>
|
||||
|
||||
-using U_ICU_NAMESPACE::BreakIterator;
|
||||
-using U_ICU_NAMESPACE::CharacterIterator;
|
||||
-using U_ICU_NAMESPACE::UnicodeString;
|
||||
+using icu::BreakIterator;
|
||||
+using icu::CharacterIterator;
|
||||
+using icu::UnicodeString;
|
||||
|
||||
namespace PHP {
|
||||
|
||||
--- a/ext/intl/breakiterator/rulebasedbreakiterator_methods.cpp
|
||||
+++ b/ext/intl/breakiterator/rulebasedbreakiterator_methods.cpp
|
||||
@@ -26,8 +26,8 @@ extern "C" {
|
||||
#include "../intl_convertcpp.h"
|
||||
#include "../intl_common.h"
|
||||
|
||||
-using U_ICU_NAMESPACE::RuleBasedBreakIterator;
|
||||
-using U_ICU_NAMESPACE::Locale;
|
||||
+using icu::RuleBasedBreakIterator;
|
||||
+using icu::Locale;
|
||||
|
||||
static inline RuleBasedBreakIterator *fetch_rbbi(BreakIterator_object *bio) {
|
||||
return (RuleBasedBreakIterator*)bio->biter;
|
||||
--- a/ext/intl/calendar/calendar_class.cpp
|
||||
+++ b/ext/intl/calendar/calendar_class.cpp
|
||||
@@ -34,8 +34,8 @@ extern "C" {
|
||||
#include <assert.h>
|
||||
}
|
||||
|
||||
-using U_ICU_NAMESPACE::GregorianCalendar;
|
||||
-using U_ICU_NAMESPACE::Locale;
|
||||
+using icu::GregorianCalendar;
|
||||
+using icu::Locale;
|
||||
|
||||
/* {{{ Global variables */
|
||||
zend_class_entry *Calendar_ce_ptr;
|
||||
--- a/ext/intl/calendar/calendar_class.h
|
||||
+++ b/ext/intl/calendar/calendar_class.h
|
||||
@@ -27,7 +27,7 @@
|
||||
#ifndef USE_CALENDAR_POINTER
|
||||
typedef void Calendar;
|
||||
#else
|
||||
-using U_ICU_NAMESPACE::Calendar;
|
||||
+using icu::Calendar;
|
||||
#endif
|
||||
|
||||
typedef struct {
|
||||
--- a/ext/intl/calendar/calendar_methods.cpp
|
||||
+++ b/ext/intl/calendar/calendar_methods.cpp
|
||||
@@ -40,7 +40,7 @@ extern "C" {
|
||||
}
|
||||
#include "../common/common_enum.h"
|
||||
|
||||
-using U_ICU_NAMESPACE::Locale;
|
||||
+using icu::Locale;
|
||||
|
||||
U_CFUNC PHP_METHOD(IntlCalendar, __construct)
|
||||
{
|
||||
--- a/ext/intl/calendar/gregoriancalendar_methods.cpp
|
||||
+++ b/ext/intl/calendar/gregoriancalendar_methods.cpp
|
||||
@@ -36,10 +36,10 @@ extern "C" {
|
||||
#include "zend_exceptions.h"
|
||||
}
|
||||
|
||||
-using U_ICU_NAMESPACE::GregorianCalendar;
|
||||
-using U_ICU_NAMESPACE::Locale;
|
||||
-using U_ICU_NAMESPACE::UnicodeString;
|
||||
-using U_ICU_NAMESPACE::StringPiece;
|
||||
+using icu::GregorianCalendar;
|
||||
+using icu::Locale;
|
||||
+using icu::UnicodeString;
|
||||
+using icu::StringPiece;
|
||||
|
||||
static inline GregorianCalendar *fetch_greg(Calendar_object *co) {
|
||||
return (GregorianCalendar*)co->ucal;
|
||||
--- a/ext/intl/common/common_date.cpp
|
||||
+++ b/ext/intl/common/common_date.cpp
|
||||
@@ -25,8 +25,8 @@ extern "C" {
|
||||
#include <ext/date/php_date.h>
|
||||
}
|
||||
|
||||
-using U_ICU_NAMESPACE::TimeZone;
|
||||
-using U_ICU_NAMESPACE::UnicodeString;
|
||||
+using icu::TimeZone;
|
||||
+using icu::UnicodeString;
|
||||
|
||||
#include "zend_portability.h"
|
||||
|
||||
--- a/ext/intl/common/common_date.h
|
||||
+++ b/ext/intl/common/common_date.h
|
||||
@@ -28,7 +28,7 @@ U_CDECL_END
|
||||
|
||||
#include <unicode/timezone.h>
|
||||
|
||||
-using U_ICU_NAMESPACE::TimeZone;
|
||||
+using icu::TimeZone;
|
||||
|
||||
U_CFUNC TimeZone *timezone_convert_datetimezone(int type, void *object, int is_datetime, intl_error *outside_error, const char *func);
|
||||
U_CFUNC int intl_datetime_decompose(zval *z, double *millis, TimeZone **tz,
|
||||
--- a/ext/intl/common/common_enum.h
|
||||
+++ b/ext/intl/common/common_enum.h
|
||||
@@ -75,7 +75,7 @@ U_CFUNC zval *zoi_with_current_get_curre
|
||||
U_CFUNC void zoi_with_current_invalidate_current(zend_object_iterator *iter);
|
||||
|
||||
#ifdef __cplusplus
|
||||
-using U_ICU_NAMESPACE::StringEnumeration;
|
||||
+using icu::StringEnumeration;
|
||||
U_CFUNC void IntlIterator_from_StringEnumeration(StringEnumeration *se, zval *object);
|
||||
#endif
|
||||
|
||||
--- a/ext/intl/dateformat/dateformat_format_object.cpp
|
||||
+++ b/ext/intl/dateformat/dateformat_format_object.cpp
|
||||
@@ -33,11 +33,11 @@ extern "C" {
|
||||
#include "../common/common_date.h"
|
||||
}
|
||||
|
||||
-using U_ICU_NAMESPACE::Locale;
|
||||
-using U_ICU_NAMESPACE::DateFormat;
|
||||
-using U_ICU_NAMESPACE::GregorianCalendar;
|
||||
-using U_ICU_NAMESPACE::StringPiece;
|
||||
-using U_ICU_NAMESPACE::SimpleDateFormat;
|
||||
+using icu::Locale;
|
||||
+using icu::DateFormat;
|
||||
+using icu::GregorianCalendar;
|
||||
+using icu::StringPiece;
|
||||
+using icu::SimpleDateFormat;
|
||||
|
||||
static const DateFormat::EStyle valid_styles[] = {
|
||||
DateFormat::kNone,
|
||||
--- a/ext/intl/dateformat/dateformat_helpers.cpp
|
||||
+++ b/ext/intl/dateformat/dateformat_helpers.cpp
|
||||
@@ -28,7 +28,7 @@ extern "C" {
|
||||
#include "../calendar/calendar_class.h"
|
||||
}
|
||||
|
||||
-using U_ICU_NAMESPACE::GregorianCalendar;
|
||||
+using icu::GregorianCalendar;
|
||||
|
||||
int datefmt_process_calendar_arg(zval* calendar_zv,
|
||||
Locale const& locale,
|
||||
--- a/ext/intl/dateformat/dateformat_helpers.h
|
||||
+++ b/ext/intl/dateformat/dateformat_helpers.h
|
||||
@@ -28,9 +28,9 @@ extern "C" {
|
||||
#include "../php_intl.h"
|
||||
}
|
||||
|
||||
-using U_ICU_NAMESPACE::Locale;
|
||||
-using U_ICU_NAMESPACE::Calendar;
|
||||
-using U_ICU_NAMESPACE::DateFormat;
|
||||
+using icu::Locale;
|
||||
+using icu::Calendar;
|
||||
+using icu::DateFormat;
|
||||
|
||||
int datefmt_process_calendar_arg(zval* calendar_zv,
|
||||
Locale const& locale,
|
||||
--- a/ext/intl/intl_convertcpp.h
|
||||
+++ b/ext/intl/intl_convertcpp.h
|
||||
@@ -26,7 +26,7 @@
|
||||
#include <unicode/unistr.h>
|
||||
#include <zend_types.h>
|
||||
|
||||
-using U_ICU_NAMESPACE::UnicodeString;
|
||||
+using icu::UnicodeString;
|
||||
|
||||
int intl_stringFromChar(UnicodeString &ret, char *str, size_t str_len, UErrorCode *status);
|
||||
|
||||
--- a/ext/intl/msgformat/msgformat_helpers.cpp
|
||||
+++ b/ext/intl/msgformat/msgformat_helpers.cpp
|
||||
@@ -76,15 +76,15 @@ MessageFormatAdapter::getMessagePattern(
|
||||
#endif
|
||||
U_NAMESPACE_END
|
||||
|
||||
-using U_ICU_NAMESPACE::Formattable;
|
||||
-using U_ICU_NAMESPACE::Format;
|
||||
-using U_ICU_NAMESPACE::DateFormat;
|
||||
-using U_ICU_NAMESPACE::MessageFormat;
|
||||
+using icu::Formattable;
|
||||
+using icu::Format;
|
||||
+using icu::DateFormat;
|
||||
+using icu::MessageFormat;
|
||||
#ifdef HAS_MESSAGE_PATTERN
|
||||
-using U_ICU_NAMESPACE::MessagePattern;
|
||||
+using icu::MessagePattern;
|
||||
#endif
|
||||
-using U_ICU_NAMESPACE::MessageFormatAdapter;
|
||||
-using U_ICU_NAMESPACE::FieldPosition;
|
||||
+using icu::MessageFormatAdapter;
|
||||
+using icu::FieldPosition;
|
||||
|
||||
U_CFUNC int32_t umsg_format_arg_count(UMessageFormat *fmt)
|
||||
{
|
||||
--- a/ext/intl/timezone/timezone_class.cpp
|
||||
+++ b/ext/intl/timezone/timezone_class.cpp
|
||||
@@ -37,7 +37,7 @@ extern "C" {
|
||||
#include <ext/date/php_date.h>
|
||||
}
|
||||
|
||||
-using U_ICU_NAMESPACE::Calendar;
|
||||
+using icu::Calendar;
|
||||
|
||||
/* {{{ Global variables */
|
||||
U_CDECL_BEGIN
|
||||
--- a/ext/intl/timezone/timezone_class.h
|
||||
+++ b/ext/intl/timezone/timezone_class.h
|
||||
@@ -30,7 +30,7 @@
|
||||
#ifndef USE_TIMEZONE_POINTER
|
||||
typedef void TimeZone;
|
||||
#else
|
||||
-using U_ICU_NAMESPACE::TimeZone;
|
||||
+using icu::TimeZone;
|
||||
#endif
|
||||
|
||||
typedef struct {
|
||||
--- a/ext/intl/timezone/timezone_methods.cpp
|
||||
+++ b/ext/intl/timezone/timezone_methods.cpp
|
||||
@@ -38,8 +38,8 @@ extern "C" {
|
||||
}
|
||||
#include "common/common_enum.h"
|
||||
|
||||
-using U_ICU_NAMESPACE::Locale;
|
||||
-using U_ICU_NAMESPACE::Calendar;
|
||||
+using icu::Locale;
|
||||
+using icu::Calendar;
|
||||
|
||||
U_CFUNC PHP_METHOD(IntlTimeZone, __construct)
|
||||
{
|
Loading…
Reference in a new issue