Merge pull request #8860 from neheb/uw
uwsgi-cgi: Fix compilation under uClibc-ng
This commit is contained in:
commit
cfc5987863
2 changed files with 12 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=uwsgi-cgi
|
||||
PKG_VERSION:=2.0.18
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_URL= \
|
||||
https://projects.unbit.it/downloads \
|
||||
|
|
11
net/uwsgi-cgi/patches/010-uclibc-ng.patch
Normal file
11
net/uwsgi-cgi/patches/010-uclibc-ng.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/core/uwsgi.c
|
||||
+++ b/core/uwsgi.c
|
||||
@@ -1820,7 +1820,7 @@ void uwsgi_plugins_atexit(void) {
|
||||
|
||||
void uwsgi_backtrace(int depth) {
|
||||
|
||||
-#if defined(__GLIBC__) || (defined(__APPLE__) && !defined(NO_EXECINFO)) || defined(UWSGI_HAS_EXECINFO)
|
||||
+#if (!defined(__UCLIBC__) && defined(__GLIBC__)) || (defined(__APPLE__) && !defined(NO_EXECINFO)) || defined(UWSGI_HAS_EXECINFO)
|
||||
|
||||
#include <execinfo.h>
|
||||
|
Loading…
Reference in a new issue