php7: fix bind_textdomain_codeset detection (refs #4250)

The gettext extension is only useful when linked against libintl-full
package, however, the detection did not work sucessfully. This patch
by @Dimazhan fixes this.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
Michael Heimpold 2017-04-11 23:31:34 +02:00
parent 4823feef13
commit cf75d8a0f9
2 changed files with 12 additions and 1 deletions

View file

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=7.1.3
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>

View file

@ -0,0 +1,11 @@
--- a/ext/gettext/config.m4
+++ b/ext/gettext/config.m4
@@ -32,3 +32,2 @@
)
- LDFLAGS=$O_LDFLAGS
@@ -48,3 +48,4 @@
AC_CHECK_LIB($GETTEXT_CHECK_IN_LIB, bind_textdomain_codeset, [AC_DEFINE(HAVE_BIND_TEXTDOMAIN_CODESET, 1, [ ])])
+ LDFLAGS=$O_LDFLAGS
fi