Merge pull request #22511 from stangri/master-https-dns-proxy
https-dns-proxy: bugfix: crashes on logging from upstream
This commit is contained in:
commit
cf5b553c81
4 changed files with 9 additions and 20 deletions
|
@ -1,14 +1,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=https-dns-proxy
|
||||
PKG_VERSION:=2023-05-25
|
||||
PKG_RELEASE:=8
|
||||
PKG_VERSION:=2023-10-25
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy/
|
||||
PKG_SOURCE_DATE:=$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=d03e11572562f008f68df217a7378628f1bb7b79
|
||||
PKG_MIRROR_HASH:=5af3683c48bc9e493ca2761a6f7ee756431692a695d6008f61b8b92431036dca
|
||||
PKG_SOURCE_VERSION:=977341a4e35a37ee454e97e82caf4276b1b4961a
|
||||
PKG_MIRROR_HASH:=8622846f1038ac05436a48d9b36a07c516cbb6504ce68e7ee8c5529788fac39b
|
||||
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
|
|
@ -5,10 +5,10 @@
|
|||
endif()
|
||||
|
||||
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra --pedantic -Wno-strict-aliasing -Wno-variadic-macros")
|
||||
-set(CMAKE_C_FLAGS_DEBUG "-g -DDEBUG")
|
||||
-set(CMAKE_C_FLAGS_DEBUG "-gdwarf-4 -DDEBUG")
|
||||
-set(CMAKE_C_FLAGS_RELEASE "-O2")
|
||||
+#set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra --pedantic -Wno-strict-aliasing -Wno-variadic-macros")
|
||||
+#set(CMAKE_C_FLAGS_DEBUG "-g -DDEBUG")
|
||||
+#set(CMAKE_C_FLAGS_DEBUG "-gdwarf-4 -DDEBUG")
|
||||
+#set(CMAKE_C_FLAGS_RELEASE "-O2")
|
||||
|
||||
if ((CMAKE_C_COMPILER_ID MATCHES GNU AND CMAKE_C_COMPILER_VERSION VERSION_GREATER_EQUAL 9) OR
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- a/src/options.c
|
||||
+++ b/src/options.c
|
||||
@@ -22,7 +22,7 @@ const char * options_sw_version() {
|
||||
@@ -24,7 +24,7 @@ const char * options_sw_version(void) {
|
||||
#ifdef SW_VERSION
|
||||
return SW_VERSION;
|
||||
#else
|
||||
- return "2023.01.01-atLeast"; // update date sometimes, like 1-2 times a year
|
||||
+ return "2023-05-25-1"; // update date sometimes, like 1-2 times a year
|
||||
- return "2023.10.10-atLeast"; // update date sometimes, like 1-2 times a year
|
||||
+ return "2023-10-25-1"; // update date sometimes, like 1-2 times a year
|
||||
#endif
|
||||
}
|
||||
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/src/logging.c
|
||||
+++ b/src/logging.c
|
||||
@@ -78,7 +78,7 @@ void _log(const char *file, int line, in
|
||||
|
||||
struct timeval tv;
|
||||
gettimeofday(&tv, NULL);
|
||||
- fprintf(logf, "%s %8lu.%06lu %s:%d ", SeverityStr[severity],
|
||||
+ fprintf(logf, "%s %8llu.%06llu %s:%d ", SeverityStr[severity],
|
||||
(uint64_t)tv.tv_sec,
|
||||
(uint64_t)tv.tv_usec, file, line);
|
||||
|
Loading…
Reference in a new issue