rp-pppoe: fix linker errors
Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
3412ddb2c0
commit
cf3e9c3f71
1 changed files with 12 additions and 0 deletions
12
net/rp-pppoe/patches/130-static-lib-fix.patch
Normal file
12
net/rp-pppoe/patches/130-static-lib-fix.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -139,7 +139,8 @@ plugin/plugin.o: plugin.c
|
||||
@CC@ -DPLUGIN=1 '-DRP_VERSION="$(VERSION)"' $(CFLAGS) -I$(PPPD_INCDIR) -c -o $@ -fPIC $<
|
||||
|
||||
plugin/libplugin.a: plugin/discovery.o plugin/if.o plugin/common.o plugin/debug.o
|
||||
- ar -rc $@ $^
|
||||
+ $(AR) -rc $@ $^
|
||||
+ @RANLIB@ $@
|
||||
|
||||
plugin/discovery.o: discovery.c
|
||||
@CC@ -DPLUGIN=1 $(CFLAGS) '-DVERSION="$(VERSION)"' -c -o $@ -fPIC $<
|
Loading…
Reference in a new issue