Merge pull request #8513 from bmork/conserver
conserver: update to 8.2.4 and enable IPv6 support
This commit is contained in:
commit
ceb1965cb8
4 changed files with 3451 additions and 17 deletions
|
@ -8,15 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=conserver
|
||||
PKG_VERSION:=8.2.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=8.2.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Bjørn Mork <bjorn@mork.no>
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/conserver/conserver.git
|
||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/conserver/conserver/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MIRROR_HASH:=27d92e6c04e97cd0884774eace0b44f30087695927bcce8addc11dba9c090d7c
|
||||
PKG_HASH:=8d8b263d9531ebb827257bd67baf9200cac4fb7ffbe033122686e39ca42cddd6
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
@ -57,10 +55,17 @@ endef
|
|||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-openssl \
|
||||
$(if $(CONFIG_IPV6),--with-ipv6) \
|
||||
--sysconfdir=/etc/conserver \
|
||||
--with-port=3109 \
|
||||
--with-logfile=/var/log/conserver/server.log
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
$(CP) ./files/config.sub $(PKG_BUILD_DIR)/
|
||||
$(CP) ./files/config.guess $(PKG_BUILD_DIR)/
|
||||
endef
|
||||
|
||||
define Package/conserver/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/conserver $(1)/usr/sbin/
|
||||
|
|
1645
net/conserver/files/config.guess
vendored
Normal file
1645
net/conserver/files/config.guess
vendored
Normal file
File diff suppressed because it is too large
Load diff
1795
net/conserver/files/config.sub
vendored
Normal file
1795
net/conserver/files/config.sub
vendored
Normal file
File diff suppressed because it is too large
Load diff
|
@ -1,11 +0,0 @@
|
|||
--- a/conserver/cutil.h
|
||||
+++ b/conserver/cutil.h
|
||||
@@ -7,6 +7,8 @@
|
||||
#include <stdarg.h>
|
||||
#if HAVE_OPENSSL
|
||||
# include <openssl/ssl.h>
|
||||
+# include <openssl/bn.h>
|
||||
+# include <openssl/dh.h>
|
||||
# include <openssl/err.h>
|
||||
# if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
# define TLS_method SSLv23_method
|
Loading…
Reference in a new issue