diff --git a/sound/forked-daapd/Makefile b/sound/forked-daapd/Makefile
index b33bb44fb..63452e1f5 100644
--- a/sound/forked-daapd/Makefile
+++ b/sound/forked-daapd/Makefile
@@ -8,15 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=forked-daapd
-PKG_VERSION:=24.2
+PKG_VERSION:=25.0
 PKG_RELEASE:=1
-PKG_REV:=1b6283752ed0b790a6658bed1f05946e1af193da
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://github.com/ejurgensen/forked-daapd.git
-PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE:=$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/archive/
+PKG_HASH:=3566f416e929591ab4fab7f99580ae5b58b99607b5abb695ac8329efaafe019c
 
 PKG_BUILD_DEPENDS:=gperf/host
 PKG_FIXUP:=autoreconf
@@ -38,7 +35,7 @@ URL:=https://github.com/ejurgensen/forked-daapd
 DEPENDS:=+libgpg-error +libgcrypt +libgdbm +zlib +libexpat +libunistring \
 	+libevent2 +libdaemon +libantlr3c +confuse +alsa-lib +libffmpeg-full \
 	+mxml +libavahi-client +sqlite3-cli +libplist +libcurl +libjson-c \
-	+libprotobuf-c +libgnutls $(ICONV_DEPENDS)
+	+libprotobuf-c +libgnutls +libsodium $(ICONV_DEPENDS)
 endef
 
 define Package/forked-daapd/description
@@ -56,7 +53,10 @@ CONFIGURE_ARGS += \
 	--enable-itunes \
 	--enable-lastfm \
 	--enable-mpd \
-	--enable-chromecast
+	--enable-chromecast \
+	--enable-verification \
+	--disable-spotify \
+	--without-libevent_pthreads
 
 TARGET_CFLAGS += $(FPIC)
 TARGET_LDFLAGS += -Wl,-rpath-link,$(STAGING_DIR)/usr/lib