Merge pull request #9771 from neheb/gif
giflib: Update to 5.2.1 and add utilities
This commit is contained in:
commit
cd6e4f1131
2 changed files with 33 additions and 26 deletions
|
@ -8,21 +8,20 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=giflib
|
PKG_NAME:=giflib
|
||||||
PKG_VERSION:=5.1.4
|
PKG_VERSION:=5.2.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/giflib
|
PKG_SOURCE_URL:=@SF/giflib
|
||||||
PKG_HASH:=df27ec3ff24671f80b29e6ab1c4971059c14ac3db95406884fc26574631ba8d5
|
PKG_HASH:=31da5562f44c5f15d63340a09a4fd62b48c45620cd302f77a6d9acf0077879bd
|
||||||
|
|
||||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
PKG_CPE_ID:=cpe:/a:giflib_project:giflib
|
PKG_CPE_ID:=cpe:/a:giflib_project:giflib
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_INSTALL:=1
|
||||||
PKG_REMOVE_FILES:=autogen.sh aclocal.m4
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
@ -31,7 +30,7 @@ define Package/giflib
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=GIF libraries
|
TITLE:=GIF libraries
|
||||||
URL:=http://sourceforge.net/projects/giflib
|
URL:=https://sourceforge.net/projects/giflib
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/giflib/description
|
define Package/giflib/description
|
||||||
|
@ -40,24 +39,42 @@ define Package/giflib/description
|
||||||
the LZW compression algorithm was patented.
|
the LZW compression algorithm was patented.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
define Package/giflib-utils
|
||||||
|
SECTION:=utils
|
||||||
define Build/Compile
|
CATEGORY:=Utilities
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
TITLE:=GIF utilities
|
||||||
|
URL:=https://sourceforge.net/projects/giflib
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/giflib-utils/description
|
||||||
|
These are the utilities that come with giflib.
|
||||||
|
endef
|
||||||
|
|
||||||
|
TARGET_CFLAGS += -ffunction-sections -fdata-sections $(FPIC)
|
||||||
|
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||||
|
|
||||||
|
MAKE_FLAGS += \
|
||||||
|
CFLAGS="$(TARGET_CFLAGS)" \
|
||||||
|
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||||
|
PREFIX=$(CONFIGURE_PREFIX)
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) $(1)/usr/{lib,include}
|
$(INSTALL_DIR) $(1)/usr/{lib,include}
|
||||||
$(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgif.so* $(1)/usr/lib
|
||||||
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libgif.a $(1)/usr/lib
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libgif.a $(1)/usr/lib
|
||||||
$(CP) $(PKG_BUILD_DIR)/lib/libgif.la $(1)/usr/lib
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include
|
||||||
$(CP) $(PKG_BUILD_DIR)/lib/*.h $(1)/usr/include/
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/giflib/install
|
define Package/giflib/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgif.so* $(1)/usr/lib
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/giflib-utils/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call HostBuild))
|
$(eval $(call HostBuild))
|
||||||
$(eval $(call BuildPackage,giflib))
|
$(eval $(call BuildPackage,giflib))
|
||||||
|
$(eval $(call BuildPackage,giflib-utils))
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -21,7 +21,6 @@ AC_PROG_MAKE_SET
|
|
||||||
AM_PROG_CC_C_O
|
|
||||||
|
|
||||||
dnl Allow partial building on systems without xmlto
|
|
||||||
-AC_CHECK_PROG([have_xmlto], [xmlto], ["yes"],["no"])
|
|
||||||
AM_CONDITIONAL([BUILD_DOC], [test "x${have_xmlto}" = "xyes"])
|
|
||||||
|
|
||||||
dnl Shared-library version
|
|
Loading…
Reference in a new issue