ovn: bump to version 22.03.0
libovn now depends on libopenvswitch since ovn 21.09.0 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
This commit is contained in:
parent
b1b37995e1
commit
cd51e3de5f
4 changed files with 33 additions and 7 deletions
|
@ -9,13 +9,13 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
include ../openvswitch/openvswitch.mk
|
||||
|
||||
PKG_NAME:=ovn
|
||||
PKG_VERSION:=20.12.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=22.03.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/ovn-org/ovn.git
|
||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||
PKG_MIRROR_HASH:=6d1b5d907b4445e84653527ccf5977b05555c785f90587dee0fc1950d96727cc
|
||||
PKG_MIRROR_HASH:=eb494796a7a21e7c1ba5b3f60c037385eb5f0c33007ebc627437f36187f860fe
|
||||
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
@ -35,7 +35,7 @@ include ../../lang/python/python3-host.mk
|
|||
|
||||
ovs_libovn_title:=Open vSwitch (libovn.so)
|
||||
ovs_libovn_hidden:=1
|
||||
ovs_libovn_depends+=+libatomic
|
||||
ovs_libovn_depends+=+libatomic +openvswitch-libopenvswitch
|
||||
ovs_libovn_files:=usr/lib/libovn*.so*
|
||||
$(eval $(call OvsPackageTemplate,libovn))
|
||||
|
||||
|
@ -88,6 +88,11 @@ CONFIGURE_VARS += \
|
|||
|
||||
|
||||
TARGET_CFLAGS += -flto -std=gnu99
|
||||
# This is needed otherwise libtool --mode=install libovn.la will fail with
|
||||
# "cannot find -lopenvswitch" when doing libtool --mode=relink. Likely this
|
||||
# was caused by libovn now depends on libopenvswitch.la (installed=no) since
|
||||
# upstream commit 1b587c4f ("controller: add datapath meter capability check")
|
||||
TARGET_LDFLAGS += -L$(ovs_builddir)/lib/.libs
|
||||
MAKE_VARS += PYTHONPATH="$(HOST_PYTHON3PATH)"
|
||||
|
||||
$(foreach p,$(ovs_packages),\
|
||||
|
|
|
@ -10,11 +10,11 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -130,7 +130,6 @@ OVS_CHECK_LINUX_HOST
|
||||
@@ -131,7 +131,6 @@ OVS_CHECK_LINUX_HOST
|
||||
OVS_LIBTOOL_VERSIONS
|
||||
OVS_CHECK_CXX
|
||||
AX_FUNC_POSIX_MEMALIGN
|
||||
-OVN_CHECK_UNBOUND
|
||||
OVS_CHECK_DDLOG_FAST_BUILD
|
||||
|
||||
OVS_CHECK_INCLUDE_NEXT([stdio.h string.h])
|
||||
AC_CONFIG_FILES([lib/libovn.sym])
|
||||
|
|
|
@ -10,7 +10,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|||
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -479,11 +479,9 @@ dist-docs:
|
||||
@@ -483,11 +483,9 @@ dist-docs:
|
||||
|
||||
|
||||
include automake.mk
|
||||
|
|
|
@ -0,0 +1,21 @@
|
|||
Fix the following compilation errors
|
||||
|
||||
ic/ovn-ic.c: In function 'main':
|
||||
ic/ovn-ic.c:689:5: warning: 'ls' may be used uninitialized in this function [-Wmaybe-uninitialized]
|
||||
689 | nbrec_logical_switch_update_ports_addvalue(ls, lsp);
|
||||
| ^
|
||||
ic/ovn-ic.c:430:40: note: 'ls' was declared here
|
||||
430 | const struct nbrec_logical_switch *ls;
|
||||
| ^
|
||||
|
||||
--- a/ic/ovn-ic.c
|
||||
+++ b/ic/ovn-ic.c
|
||||
@@ -427,7 +427,7 @@ find_ts_in_nb(struct ic_context *ctx, ch
|
||||
nbrec_logical_switch_index_init_row(ctx->nbrec_ls_by_name);
|
||||
nbrec_logical_switch_index_set_name(key, ts_name);
|
||||
|
||||
- const struct nbrec_logical_switch *ls;
|
||||
+ const struct nbrec_logical_switch *ls = NULL;
|
||||
bool found = false;
|
||||
NBREC_LOGICAL_SWITCH_FOR_EACH_EQUAL (ls, key, ctx->nbrec_ls_by_name) {
|
||||
const char *ls_ts_name = smap_get(&ls->other_config, "interconn-ts");
|
Loading…
Reference in a new issue