bluez: Update to version 5.54
Signed-off-by: Bruno Randolf <br1@einfach.org>
This commit is contained in:
parent
c11aaead91
commit
cd26214d0e
4 changed files with 23 additions and 19 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bluez
|
||||
PKG_VERSION:=5.51
|
||||
PKG_VERSION:=5.54
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
|
||||
PKG_HASH:=ebedfb359f62957940822f1d0b39fcee30422380e435608dad06bb3913d5ebba
|
||||
PKG_HASH:=68cdab9e63e8832b130d5979dc8c96fdb087b31278f342874d992af3e56656dc
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
--- bluez-5.51.orig/Makefile.in
|
||||
+++ bluez-5.51/Makefile.in
|
||||
@@ -3125,7 +3125,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
Index: bluez-5.54/Makefile.in
|
||||
===================================================================
|
||||
--- bluez-5.54.orig/Makefile.in
|
||||
+++ bluez-5.54/Makefile.in
|
||||
@@ -3214,7 +3214,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@CLIENT_TRUE@ client/gatt.h client/gatt.c
|
||||
|
||||
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||
|
@ -9,16 +11,16 @@
|
|||
|
||||
@ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
|
||||
@ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
|
||||
@@ -3358,7 +3358,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3452,7 +3452,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
|
||||
@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||
@MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
|
||||
-@MESH_TRUE@@TOOLS_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline
|
||||
+@MESH_TRUE@@TOOLS_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline -lncurses
|
||||
|
||||
@DEPRECATED_TRUE@@TOOLS_TRUE@tools_hciattach_SOURCES = tools/hciattach.c tools/hciattach.h \
|
||||
@DEPRECATED_TRUE@@TOOLS_TRUE@ tools/hciattach_st.c \
|
||||
@@ -3411,7 +3411,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
|
||||
@MESH_TRUE@@TOOLS_TRUE@ tools/mesh/model.h tools/mesh/config-model.h \
|
||||
@@ -3520,7 +3520,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@READLINE_TRUE@ tools/obex-client-tool.c
|
||||
|
||||
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
|
||||
|
@ -27,7 +29,7 @@
|
|||
|
||||
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
|
||||
@READLINE_TRUE@ tools/obex-server-tool.c
|
||||
@@ -3420,15 +3420,15 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3529,15 +3529,15 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
|
||||
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
|
||||
@READLINE_TRUE@ src/libshared-glib.la \
|
||||
|
@ -46,7 +48,7 @@
|
|||
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
|
||||
@@ -3437,7 +3437,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3546,7 +3546,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
|
||||
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
|
||||
|
|
|
@ -1,10 +1,12 @@
|
|||
--- a/src/shared/util.h
|
||||
+++ b/src/shared/util.h
|
||||
Index: bluez-5.53/src/shared/util.h
|
||||
===================================================================
|
||||
--- bluez-5.53.orig/src/shared/util.h
|
||||
+++ bluez-5.53/src/shared/util.h
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <alloca.h>
|
||||
#include <byteswap.h>
|
||||
#include <string.h>
|
||||
+#include <endian.h>
|
||||
|
||||
#if __BYTE_ORDER == __LITTLE_ENDIAN
|
||||
#define le16_to_cpu(val) (val)
|
||||
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
|
||||
|
||||
|
|
|
@ -32,11 +32,11 @@ This commit prevents the call to btd_adv_manager_refresh for non-LE devices.
|
|||
src/adapter.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
Index: bluez-5.51/src/adapter.c
|
||||
Index: bluez-5.54/src/adapter.c
|
||||
===================================================================
|
||||
--- bluez-5.51.orig/src/adapter.c
|
||||
+++ bluez-5.51/src/adapter.c
|
||||
@@ -546,7 +546,8 @@ static void settings_changed(struct btd_
|
||||
--- bluez-5.54.orig/src/adapter.c
|
||||
+++ bluez-5.54/src/adapter.c
|
||||
@@ -567,7 +567,8 @@ static void settings_changed(struct btd_
|
||||
g_dbus_emit_property_changed(dbus_conn, adapter->path,
|
||||
ADAPTER_INTERFACE, "Discoverable");
|
||||
store_adapter_info(adapter);
|
||||
|
|
Loading…
Reference in a new issue