getdns: update to version 1.5.0
Signed-off-by: Jonathan G. Underwood <jonathan.underwood@gmail.com>
This commit is contained in:
parent
07e6476454
commit
ccf0c71ace
2 changed files with 10 additions and 35 deletions
|
@ -5,8 +5,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=getdns
|
||||
PKG_VERSION:=1.4.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.5.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
@ -14,7 +14,7 @@ PKG_MAINTAINER:=Jonathan Underwood <jonathan.underwood@gmail.com>
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://getdnsapi.net/dist/
|
||||
PKG_HASH:=1685b82dfe297cffc4bae08a773cdc88a3edf9a4e5a1ea27d8764bb5affc0e80
|
||||
PKG_HASH:=577182c3ace919ee70cee5629505581a10dc530bd53fe5c241603ea91c84fa84
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
|
@ -22,8 +22,8 @@ PKG_INSTALL:=1
|
|||
|
||||
PKG_CONFIG_DEPENDS:= \
|
||||
CONFIG_GETDNS_ENABLE_STUB_ONLY \
|
||||
CONFIG_GETDNS_ENABLE_IDN_LIBIDN2
|
||||
|
||||
CONFIG_GETDNS_ENABLE_IDN_LIBIDN2
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/getdns/Default
|
||||
|
@ -41,7 +41,7 @@ define Package/getdns
|
|||
endef
|
||||
|
||||
define Package/getdns/description
|
||||
This package contains the getdns library (libgetdns).
|
||||
This package contains the getdns library (libgetdns).
|
||||
This package also contains the "getdns_query" command line wrapper for getdns exposing the features of this implementation (both in the official API and the additional API functions).
|
||||
endef
|
||||
|
||||
|
@ -56,7 +56,7 @@ CONFIGURE_ARGS += \
|
|||
--with-ssl="$(STAGING_DIR)/usr" \
|
||||
|
||||
# This will make 'configure' think that our libbsd.so is missing the
|
||||
# functions inet_pton, inet_ntop, strlcpy and use the builtin. This
|
||||
# functions inet_pton, inet_ntop, strlcpy and use the builtin. This
|
||||
# removes the libbsd dependency
|
||||
CONFIGURE_VARS += LIBBSD_LIBS=-lc
|
||||
|
||||
|
@ -68,12 +68,12 @@ define Build/InstallDev
|
|||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/getdns*.pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
|
||||
|
||||
|
||||
define Package/getdns/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libgetdns.so.* $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/getdns_query $(1)/usr/sbin/getdns_query
|
||||
endef
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From 05bce5263735b77f91078a930ec55b9cf181d999 Mon Sep 17 00:00:00 2001
|
||||
From: Willem Toorop <willem@nlnetlabs.nl>
|
||||
Date: Sun, 13 May 2018 11:59:14 +0200
|
||||
Subject: [PATCH] Bugfix #399: Reinclude <linux/sysctl.h> in getentropy_linux.c
|
||||
|
||||
---
|
||||
src/compat/getentropy_linux.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/compat/getentropy_linux.c b/src/compat/getentropy_linux.c
|
||||
index 744783c..abb28f4 100644
|
||||
--- a/src/compat/getentropy_linux.c
|
||||
+++ b/src/compat/getentropy_linux.c
|
||||
@@ -62,6 +62,7 @@
|
||||
|
||||
#include <linux/types.h>
|
||||
#include <linux/random.h>
|
||||
+#include <linux/sysctl.h>
|
||||
#ifdef HAVE_GETAUXVAL
|
||||
#include <sys/auxv.h>
|
||||
#endif
|
||||
--
|
||||
2.14.1
|
||||
|
||||
|
Loading…
Reference in a new issue