ipmitool: fix compilation with GCC10
Upstream backport. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
f48625cbf9
commit
cc5c8b4368
2 changed files with 38 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=ipmitool
|
||||
PKG_VERSION:=1.8.18
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
|
|
37
admin/ipmitool/patches/0012-gcc10.patch
Normal file
37
admin/ipmitool/patches/0012-gcc10.patch
Normal file
|
@ -0,0 +1,37 @@
|
|||
From c3939dac2c060651361fc71516806f9ab8c38901 Mon Sep 17 00:00:00 2001
|
||||
From: Vaclav Dolezal <vdolezal@redhat.com>
|
||||
Date: Thu, 23 Jan 2020 11:26:32 +0100
|
||||
Subject: [PATCH] hpmfwupg: move variable definition to .c file
|
||||
|
||||
Signed-off-by: Vaclav Dolezal <vdolezal@redhat.com>
|
||||
---
|
||||
include/ipmitool/ipmi_hpmfwupg.h | 2 +-
|
||||
lib/ipmi_hpmfwupg.c | 2 ++
|
||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/include/ipmitool/ipmi_hpmfwupg.h b/include/ipmitool/ipmi_hpmfwupg.h
|
||||
index de65292b..07f597be 100644
|
||||
--- a/include/ipmitool/ipmi_hpmfwupg.h
|
||||
+++ b/include/ipmitool/ipmi_hpmfwupg.h
|
||||
@@ -800,7 +800,7 @@ typedef struct _VERSIONINFO {
|
||||
char descString[HPMFWUPG_DESC_STRING_LENGTH + 1];
|
||||
}VERSIONINFO, *PVERSIONINFO;
|
||||
|
||||
-VERSIONINFO gVersionInfo[HPMFWUPG_COMPONENT_ID_MAX];
|
||||
+extern VERSIONINFO gVersionInfo[HPMFWUPG_COMPONENT_ID_MAX];
|
||||
|
||||
#define TARGET_VER (0x01)
|
||||
#define ROLLBACK_VER (0x02)
|
||||
diff --git a/lib/ipmi_hpmfwupg.c b/lib/ipmi_hpmfwupg.c
|
||||
index 4aa8cecd..d63d2c15 100644
|
||||
--- a/lib/ipmi_hpmfwupg.c
|
||||
+++ b/lib/ipmi_hpmfwupg.c
|
||||
@@ -58,6 +58,8 @@
|
||||
|
||||
extern int verbose;
|
||||
|
||||
+VERSIONINFO gVersionInfo[HPMFWUPG_COMPONENT_ID_MAX];
|
||||
+
|
||||
int HpmfwupgUpgrade(struct ipmi_intf *intf, char *imageFilename,
|
||||
int activate, int, int);
|
||||
int HpmfwupgValidateImageIntegrity(struct HpmfwupgUpgradeCtx *pFwupgCtx);
|
Loading…
Reference in a new issue