commit
cbfa3a67e1
2 changed files with 28 additions and 4 deletions
|
@ -2,12 +2,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tmux
|
||||
PKG_VERSION:=3.1c
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=3.2
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/tmux/tmux/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=b9617dd4d1c541ebc21b6b5760d58102fc039a593786aab273b5dd95dd514bea
|
||||
PKG_HASH:=290a2f25a2f26c649f7ec7f2880586b8d3f43e24d7cb42c691f430941edb4fcf
|
||||
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
|
||||
|
||||
PKG_LICENSE:=ISC
|
||||
|
@ -25,7 +25,7 @@ define Package/tmux
|
|||
CATEGORY:=Utilities
|
||||
SUBMENU:=Terminal
|
||||
TITLE:=Terminal multiplexer
|
||||
DEPENDS:=+libncurses +libevent2 +libpthread +librt
|
||||
DEPENDS:=+libncurses +libevent2-core +libpthread +librt
|
||||
URL:=http://tmux.github.io/
|
||||
endef
|
||||
|
||||
|
|
24
utils/tmux/patches/100-add-crosscompiling-fallbacks.patch
Normal file
24
utils/tmux/patches/100-add-crosscompiling-fallbacks.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
commit bb6242675ad0c7447daef148fffced882e5b4a61
|
||||
Author: Nicholas Marriott <nicholas.marriott@gmail.com>
|
||||
Date: Thu Apr 15 06:45:19 2021 +0100
|
||||
|
||||
Add crosscompiling fallbacks, from Hasso Tepper.
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -163,6 +163,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM(
|
||||
[return (reallocarray(NULL, 1, 1) == NULL);]
|
||||
)],
|
||||
AC_MSG_RESULT(yes),
|
||||
+ [AC_LIBOBJ(reallocarray) AC_MSG_RESULT([no])],
|
||||
[AC_LIBOBJ(reallocarray) AC_MSG_RESULT([no])]
|
||||
)
|
||||
AC_MSG_CHECKING([for working recallocarray])
|
||||
@@ -171,6 +172,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM(
|
||||
[return (recallocarray(NULL, 1, 1, 1) == NULL);]
|
||||
)],
|
||||
AC_MSG_RESULT(yes),
|
||||
+ [AC_LIBOBJ(recallocarray) AC_MSG_RESULT([no])],
|
||||
[AC_LIBOBJ(recallocarray) AC_MSG_RESULT([no])]
|
||||
)
|
||||
|
Loading…
Reference in a new issue