luasocket: fix build on mpc85xx
Signed-off-by: Laurent Papier <papier[at]tuxfan.net>
This commit is contained in:
parent
2be807285a
commit
cb44bfebd5
2 changed files with 26 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=luasocket
|
||||
PKG_SOURCE_VERSION:=6d5e40c324c84d9c1453ae88e0ad5bdd0a631448
|
||||
PKG_VERSION:=3.0-rc1-20130909
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_MIRROR_HASH:=d2fa075d8bd026c41e0eb1a634ac2ad8115dee8abb070720e8e91fab51f86ee4
|
||||
|
|
25
lang/luasocket/patches/0301-Fix-mpc85xx-build.patch
Normal file
25
lang/luasocket/patches/0301-Fix-mpc85xx-build.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- a/src/makefile
|
||||
+++ b/src/makefile
|
||||
@@ -345,18 +345,18 @@ none:
|
||||
all: $(SOCKET_SO) $(MIME_SO)
|
||||
|
||||
$(SOCKET_SO): $(SOCKET_OBJS)
|
||||
- $(LD) $(SOCKET_OBJS) $(LDFLAGS)$@
|
||||
+ $(CC) $(SOCKET_OBJS) $(LDFLAGS)$@
|
||||
|
||||
$(MIME_SO): $(MIME_OBJS)
|
||||
- $(LD) $(MIME_OBJS) $(LDFLAGS)$@
|
||||
+ $(CC) $(MIME_OBJS) $(LDFLAGS)$@
|
||||
|
||||
all-unix: all $(UNIX_SO) $(SERIAL_SO)
|
||||
|
||||
$(UNIX_SO): $(UNIX_OBJS)
|
||||
- $(LD) $(UNIX_OBJS) $(LDFLAGS)$@
|
||||
+ $(CC) $(UNIX_OBJS) $(LDFLAGS)$@
|
||||
|
||||
$(SERIAL_SO): $(SERIAL_OBJS)
|
||||
- $(LD) $(SERIAL_OBJS) $(LDFLAGS)$@
|
||||
+ $(CC) $(SERIAL_OBJS) $(LDFLAGS)$@
|
||||
|
||||
install:
|
||||
$(INSTALL_DIR) $(INSTALL_TOP_LDIR)
|
Loading…
Reference in a new issue