freeradius3: Updated patches/004-fix-target-python-header-detection.patch to remove the rlm_python3 specific changes as it is no longer needed to compile and updated the Makefile to reflect this due to the following change/commit in freeradius:
307678b268
This is in preparation for the 3.0.21 update.
Signed-off-by: Robby K <robbyke@gmail.com>
This commit is contained in:
parent
4c9d290938
commit
cb10971c14
2 changed files with 1 additions and 45 deletions
|
@ -611,11 +611,7 @@ ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius3-mod-python3),)
|
|||
CFLAGS+= -fPIC
|
||||
CONFIGURE_ARGS+= \
|
||||
--with-modules="rlm_python3" \
|
||||
--with-rlm-python3-include-dir="$(PYTHON3_INC_DIR)" \
|
||||
--with-rlm-python3-lib-dir="$(PYTHON3_LIB_DIR)"
|
||||
CONFIGURE_VARS+= \
|
||||
OPENWRTTARGET_PY3_PREFIX="$(PYTHON3_DIR)" \
|
||||
OPENWRTTARGET_PY3_SYS_VERSION="$(PYTHON3_VERSION)"
|
||||
--with-rlm-python3-config-bin="$(STAGING_DIR)/host/bin/python$(PYTHON3_VERSION)-config"
|
||||
else
|
||||
CONFIGURE_ARGS+= --without-rlm_python3
|
||||
endif
|
||||
|
|
|
@ -37,44 +37,4 @@
|
|||
+ PY_SYS_VERSION="$OPENWRTTARGET_PY_SYS_VERSION"
|
||||
AC_MSG_NOTICE([Python sys.version \"${PY_SYS_VERSION}\"])
|
||||
|
||||
if test "x$PY_LIB_DIR" = "x"; then
|
||||
--- a/src/modules/rlm_python3/configure
|
||||
+++ b/src/modules/rlm_python3/configure
|
||||
@@ -2928,15 +2928,15 @@ fi
|
||||
|
||||
|
||||
if test x$fail = x; then
|
||||
- PY_PREFIX=`${PYTHON3_BIN} -c 'import sys ; print(sys.prefix)'`
|
||||
+ PY_PREFIX="$OPENWRTTARGET_PY3_PREFIX"
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: Python sys.prefix \"${PY_PREFIX}\"" >&5
|
||||
$as_echo "$as_me: Python sys.prefix \"${PY_PREFIX}\"" >&6;}
|
||||
|
||||
- PY_EXEC_PREFIX=`${PYTHON3_BIN} -c 'import sys ; print(sys.exec_prefix)'`
|
||||
+ PY_EXEC_PREFIX="$OPENWRTTARGET_PY3_PREFIX"
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: Python sys.exec_prefix \"${PY_EXEC_PREFIX}\"" >&5
|
||||
$as_echo "$as_me: Python sys.exec_prefix \"${PY_EXEC_PREFIX}\"" >&6;}
|
||||
|
||||
- PY_SYS_VERSION=`${PYTHON3_BIN} -c 'import sys ; print(sys.version[0:3])'`
|
||||
+ PY_SYS_VERSION="$OPENWRTTARGET_PY3_SYS_VERSION"
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: Python sys.version \"${PY_SYS_VERSION}\"" >&5
|
||||
$as_echo "$as_me: Python sys.version \"${PY_SYS_VERSION}\"" >&6;}
|
||||
|
||||
--- a/src/modules/rlm_python3/configure.ac
|
||||
+++ b/src/modules/rlm_python3/configure.ac
|
||||
@@ -65,13 +65,13 @@ if test x$with_[]modname != xno; then
|
||||
)
|
||||
|
||||
if test x$fail = x; then
|
||||
- PY_PREFIX=`${PYTHON3_BIN} -c 'import sys ; print(sys.prefix)'`
|
||||
+ PY_PREFIX="$OPENWRTTARGET_PY3_PREFIX"
|
||||
AC_MSG_NOTICE([Python sys.prefix \"${PY_PREFIX}\"])
|
||||
|
||||
- PY_EXEC_PREFIX=`${PYTHON3_BIN} -c 'import sys ; print(sys.exec_prefix)'`
|
||||
+ PY_EXEC_PREFIX="$OPENWRTTARGET_PY3_PREFIX"
|
||||
AC_MSG_NOTICE([Python sys.exec_prefix \"${PY_EXEC_PREFIX}\"])
|
||||
|
||||
- PY_SYS_VERSION=`${PYTHON3_BIN} -c 'import sys ; print(sys.version[[0:3]])'`
|
||||
+ PY_SYS_VERSION="$OPENWRTTARGET_PY3_SYS_VERSION"
|
||||
AC_MSG_NOTICE([Python sys.version \"${PY_SYS_VERSION}\"])
|
||||
|
||||
if test "x$PY_LIB_DIR" = "x"; then
|
||||
|
|
Loading…
Reference in a new issue