libwangle: Update to 2019.10.07.00
Added patch to remove boost-thread dependency. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
cc1b52c44a
commit
caf1a153d3
2 changed files with 25 additions and 7 deletions
|
@ -1,21 +1,19 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libwangle
|
PKG_NAME:=libwangle
|
||||||
PKG_VERSION:=2019.09.22.00
|
PKG_VERSION:=2019.10.07.00
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_VERSION:=fb79e25af6d4e184587b62475fb3444643ae8867
|
PKG_SOURCE_URL:=https://codeload.github.com/facebook/wangle/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/facebook/wangle/tar.gz/$(PKG_SOURCE_VERSION)?
|
PKG_HASH:=b030fbff5f346ba4e50e97fc452b321f1f32b215ba7a31e1538c2996b76cf1e9
|
||||||
PKG_HASH:=e973cad492d025c93af49c245b1f77b484df09a4d70ade069648d633d5a85e0e
|
PKG_BUILD_DIR:=$(BUILD_DIR)/wangle-$(PKG_VERSION)
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/wangle-$(PKG_SOURCE_VERSION)
|
|
||||||
|
|
||||||
PKG_MAINTAINER:=Amol Bhave <ambhave@fb.com>
|
PKG_MAINTAINER:=Amol Bhave <ambhave@fb.com>
|
||||||
PKG_LICENSE:=Apache-2.0
|
PKG_LICENSE:=Apache-2.0
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_BUILD_DEPENDS:=libfizz
|
|
||||||
CMAKE_SOURCE_SUBDIR:=wangle
|
CMAKE_SOURCE_SUBDIR:=wangle
|
||||||
CMAKE_INSTALL:=1
|
CMAKE_INSTALL:=1
|
||||||
|
|
||||||
|
@ -27,9 +25,18 @@ define Package/libwangle
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=Wangle: C++ networking library
|
TITLE:=Wangle: C++ networking library
|
||||||
URL:=https://github.com/facebook/wangle
|
URL:=https://github.com/facebook/wangle
|
||||||
|
DEPENDS:=+libfizz
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto
|
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections
|
||||||
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||||
|
|
||||||
|
CMAKE_OPTIONS += \
|
||||||
|
-DBUILD_SHARED_LIBS=ON
|
||||||
|
|
||||||
|
define Package/libwangle/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libwangle.so* $(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libwangle))
|
$(eval $(call BuildPackage,libwangle))
|
||||||
|
|
11
libs/libwangle/patches/020-no-boost-thread.patch
Normal file
11
libs/libwangle/patches/020-no-boost-thread.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/wangle/CMakeLists.txt
|
||||||
|
+++ b/wangle/CMakeLists.txt
|
||||||
|
@@ -56,7 +56,7 @@ if (NOT folly_FOUND)
|
||||||
|
endif()
|
||||||
|
|
||||||
|
find_package(fizz CONFIG REQUIRED)
|
||||||
|
-find_package(Boost REQUIRED COMPONENTS system thread filesystem regex context
|
||||||
|
+find_package(Boost REQUIRED COMPONENTS system filesystem regex context
|
||||||
|
program_options)
|
||||||
|
find_package(OpenSSL REQUIRED)
|
||||||
|
find_package(Glog REQUIRED)
|
Loading…
Reference in a new issue