aria2: Fix the faulty patch again
The previous solution was incorrect. The issue was that the macro was not defined as the header defining it was not included. GCC warns if -Wunder is passed and does not error by default, leading to the confusion. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
f81ef698d5
commit
cabf977d38
2 changed files with 17 additions and 9 deletions
|
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=aria2
|
PKG_NAME:=aria2
|
||||||
PKG_VERSION:=1.34.0
|
PKG_VERSION:=1.34.0
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=5
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://github.com/aria2/aria2/releases/download/release-$(PKG_VERSION)/
|
PKG_SOURCE_URL:=https://github.com/aria2/aria2/releases/download/release-$(PKG_VERSION)/
|
||||||
|
|
|
@ -1,30 +1,38 @@
|
||||||
From 0cfd523a6d0ea16d8b7c94160216838d53c30da6 Mon Sep 17 00:00:00 2001
|
From 0e31e37c0f6ad0b3f393f024d1f6d8ce448e4746 Mon Sep 17 00:00:00 2001
|
||||||
From: Rosen Penev <rosenp@gmail.com>
|
From: Rosen Penev <rosenp@gmail.com>
|
||||||
Date: Sat, 8 Dec 2018 18:39:50 -0800
|
Date: Sat, 8 Dec 2018 18:39:50 -0800
|
||||||
Subject: [PATCH] Platform: Fix compilation without deprecated OpenSSL APIs
|
Subject: [PATCH] Platform: Fix compilation without deprecated OpenSSL APIs
|
||||||
|
|
||||||
---
|
---
|
||||||
src/Platform.cc | 2 ++
|
src/Platform.cc | 3 +++
|
||||||
1 file changed, 2 insertions(+)
|
1 file changed, 3 insertions(+)
|
||||||
|
|
||||||
diff --git a/src/Platform.cc b/src/Platform.cc
|
diff --git a/src/Platform.cc b/src/Platform.cc
|
||||||
index ea73b6c6..0af62d18 100644
|
index ea73b6c6..d7882a97 100644
|
||||||
--- a/src/Platform.cc
|
--- a/src/Platform.cc
|
||||||
+++ b/src/Platform.cc
|
+++ b/src/Platform.cc
|
||||||
@@ -111,11 +111,13 @@ bool Platform::setUp()
|
@@ -44,6 +44,7 @@
|
||||||
|
#ifdef HAVE_OPENSSL
|
||||||
|
#include <openssl/err.h>
|
||||||
|
#include <openssl/ssl.h>
|
||||||
|
+#include "libssl_compat.h"
|
||||||
|
#endif // HAVE_OPENSSL
|
||||||
|
#ifdef HAVE_LIBGCRYPT
|
||||||
|
#include <gcrypt.h>
|
||||||
|
@@ -111,11 +112,13 @@ bool Platform::setUp()
|
||||||
#endif // ENABLE_NLS
|
#endif // ENABLE_NLS
|
||||||
|
|
||||||
#ifdef HAVE_OPENSSL
|
#ifdef HAVE_OPENSSL
|
||||||
+#if OPENSSL_101_API
|
+#if !OPENSSL_101_API
|
||||||
// for SSL initialization
|
// for SSL initialization
|
||||||
SSL_load_error_strings();
|
SSL_load_error_strings();
|
||||||
SSL_library_init();
|
SSL_library_init();
|
||||||
// Need this to "decrypt" p12 files.
|
// Need this to "decrypt" p12 files.
|
||||||
OpenSSL_add_all_algorithms();
|
OpenSSL_add_all_algorithms();
|
||||||
+#endif // OPENSSL_101_API
|
+#endif // !OPENSSL_101_API
|
||||||
#endif // HAVE_OPENSSL
|
#endif // HAVE_OPENSSL
|
||||||
#ifdef HAVE_LIBGCRYPT
|
#ifdef HAVE_LIBGCRYPT
|
||||||
if (!gcry_check_version("1.2.4")) {
|
if (!gcry_check_version("1.2.4")) {
|
||||||
--
|
--
|
||||||
2.20.0
|
2.17.1
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue