loudmouth: fix build
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
2d79ac1fa3
commit
ca6d16370b
2 changed files with 13 additions and 1 deletions
|
@ -31,7 +31,7 @@ include $(INCLUDE_DIR)/package.mk
|
|||
define Package/loudmouth
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+glib2 +libopenssl
|
||||
DEPENDS:=+glib2 +libopenssl +PACKAGE_krb5-libs:krb5-libs
|
||||
TITLE:=loudmouth
|
||||
URL:=https://github.com/mcabber/loudmouth
|
||||
endef
|
||||
|
|
12
libs/loudmouth/patches/002-fix-comparison.patch
Normal file
12
libs/loudmouth/patches/002-fix-comparison.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -u --recursive loudmouth-1.5.3-vanilla/loudmouth/lm-sasl.c loudmouth-1.5.3/loudmouth/lm-sasl.c
|
||||
--- loudmouth-1.5.3-vanilla/loudmouth/lm-sasl.c 2018-07-27 22:42:03.250616281 -0400
|
||||
+++ loudmouth-1.5.3/loudmouth/lm-sasl.c 2018-07-27 22:42:26.756659723 -0400
|
||||
@@ -529,7 +529,7 @@
|
||||
}
|
||||
|
||||
nonce = g_hash_table_lookup (challenge, "nonce");
|
||||
- if (nonce == NULL || nonce == '\0') {
|
||||
+ if (nonce == NULL || *nonce == '\0') {
|
||||
g_log (LM_LOG_DOMAIN, LM_LOG_LEVEL_SASL,
|
||||
"%s: server didn't provide a nonce in the challenge",
|
||||
G_STRFUNC);
|
Loading…
Reference in a new issue