bcm27xx-eeprom: update to v2022.04.26-138a1
Git compare: 47976e4409
...v2022.04.26-138a1
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
febc364214
commit
ca64c40bc4
4 changed files with 11 additions and 10 deletions
|
@ -1,12 +1,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=bcm27xx-eeprom
|
PKG_NAME:=bcm27xx-eeprom
|
||||||
PKG_VERSION:=47976e4409c6999a8e211976c75c60a97c90275c
|
PKG_VERSION:=v2022.04.26-138a1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/raspberrypi/rpi-eeprom/tar.gz/$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/raspberrypi/rpi-eeprom/tar.gz/$(PKG_VERSION)?
|
||||||
PKG_HASH:=fe67e174d897c6e29549129522c2fbce2404142e098c3c809c2a3b26b5708055
|
PKG_HASH:=7c54839e68f226c5853fb63c8a1539b729d84b2e6bac311a51766c601d10a413
|
||||||
|
|
||||||
PKG_LICENSE:=BSD-3-Clause Custom
|
PKG_LICENSE:=BSD-3-Clause Custom
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
@ -43,6 +43,7 @@ define Package/bcm27xx-eeprom/install
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rpi-eeprom-config $(1)/usr/bin
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rpi-eeprom-config $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rpi-eeprom-digest $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rpi-eeprom-update $(1)/usr/bin
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rpi-eeprom-update $(1)/usr/bin
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/lib/firmware/raspberrypi/bootloader
|
$(INSTALL_DIR) $(1)/lib/firmware/raspberrypi/bootloader
|
||||||
|
|
|
@ -24,7 +24,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
||||||
fi
|
fi
|
||||||
|
|
||||||
LOCAL_MODE=0
|
LOCAL_MODE=0
|
||||||
@@ -400,7 +400,7 @@ The system should then boot normally.
|
@@ -380,7 +380,7 @@ The system should then boot normally.
|
||||||
|
|
||||||
If /boot does not correspond to the boot partition and this
|
If /boot does not correspond to the boot partition and this
|
||||||
is not a NOOBS system, then the mount point for BOOTFS should be defined
|
is not a NOOBS system, then the mount point for BOOTFS should be defined
|
||||||
|
@ -33,7 +33,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
||||||
|
|
||||||
A backup of the current EEPROM config file is written to ${FIRMWARE_BACKUP_DIR}
|
A backup of the current EEPROM config file is written to ${FIRMWARE_BACKUP_DIR}
|
||||||
before applying the update.
|
before applying the update.
|
||||||
@@ -433,7 +433,7 @@ Options:
|
@@ -413,7 +413,7 @@ Options:
|
||||||
-u Install the specified VL805 (USB EEPROM) image file.
|
-u Install the specified VL805 (USB EEPROM) image file.
|
||||||
|
|
||||||
Environment:
|
Environment:
|
||||||
|
|
|
@ -13,7 +13,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
||||||
|
|
||||||
--- a/rpi-eeprom-update
|
--- a/rpi-eeprom-update
|
||||||
+++ b/rpi-eeprom-update
|
+++ b/rpi-eeprom-update
|
||||||
@@ -223,7 +223,7 @@ applyRecoveryUpdate()
|
@@ -200,7 +200,7 @@ applyRecoveryUpdate()
|
||||||
|| die "Failed to copy ${TMP_EEPROM_IMAGE} to ${BOOTFS}"
|
|| die "Failed to copy ${TMP_EEPROM_IMAGE} to ${BOOTFS}"
|
||||||
|
|
||||||
# For NFS mounts ensure that the files are readable to the TFTP user
|
# For NFS mounts ensure that the files are readable to the TFTP user
|
||||||
|
@ -22,7 +22,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
||||||
|| die "Failed to set permissions on eeprom update files"
|
|| die "Failed to set permissions on eeprom update files"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@@ -235,7 +235,7 @@ applyRecoveryUpdate()
|
@@ -211,7 +211,7 @@ applyRecoveryUpdate()
|
||||||
|| die "Failed to copy ${VL805_UPDATE_IMAGE} to ${BOOTFS}/vl805.bin"
|
|| die "Failed to copy ${VL805_UPDATE_IMAGE} to ${BOOTFS}/vl805.bin"
|
||||||
|
|
||||||
# For NFS mounts ensure that the files are readable to the TFTP user
|
# For NFS mounts ensure that the files are readable to the TFTP user
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/rpi-eeprom-config
|
--- a/rpi-eeprom-config
|
||||||
+++ b/rpi-eeprom-config
|
+++ b/rpi-eeprom-config
|
||||||
@@ -129,8 +129,8 @@ def edit_config(eeprom=None):
|
@@ -166,8 +166,8 @@ def edit_config(eeprom=None):
|
||||||
"""
|
"""
|
||||||
Implements something like 'git commit' for editing EEPROM configs.
|
Implements something like 'git commit' for editing EEPROM configs.
|
||||||
"""
|
"""
|
||||||
|
@ -11,7 +11,7 @@
|
||||||
if 'EDITOR' in os.environ:
|
if 'EDITOR' in os.environ:
|
||||||
editor = os.environ['EDITOR']
|
editor = os.environ['EDITOR']
|
||||||
|
|
||||||
@@ -317,7 +317,7 @@ Operating modes:
|
@@ -428,7 +428,7 @@ Operating modes:
|
||||||
|
|
||||||
To cancel the pending update run 'sudo rpi-eeprom-update -r'
|
To cancel the pending update run 'sudo rpi-eeprom-update -r'
|
||||||
|
|
||||||
|
@ -19,4 +19,4 @@
|
||||||
+ The default text editor is vi and may be overridden by setting the 'EDITOR'
|
+ The default text editor is vi and may be overridden by setting the 'EDITOR'
|
||||||
environment variable and passing '-E' to 'sudo' to preserve the environment.
|
environment variable and passing '-E' to 'sudo' to preserve the environment.
|
||||||
|
|
||||||
See 'rpi-eeprom-update -h' for more information about the available EEPROM
|
6. Signing the bootloader config file.
|
||||||
|
|
Loading…
Reference in a new issue