Merge pull request #10677 from ja-pa/measurement-kit-update

measurement-kit: add InstallDev section
This commit is contained in:
Rosen Penev 2019-12-02 13:27:59 -08:00 committed by GitHub
commit ca2449bda9
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 8 additions and 15 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=measurement-kit
PKG_VERSION:=0.10.6
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/measurement-kit/measurement-kit/tar.gz/v$(PKG_VERSION)?
@ -44,6 +44,13 @@ define Build/Configure
$(call Build/Configure/Default)
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
endef
define Package/measurement-kit/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/measurement_kit $(1)/usr/bin/

View file

@ -1,14 +0,0 @@
--- a/include/private/catch.hpp
+++ b/include/private/catch.hpp
@@ -11095,7 +11095,11 @@ bool almostEqualUlps(FP lhs, FP rhs, int maxUlpDiff) {
template <typename FP>
FP step(FP start, FP direction, int steps) {
for (int i = 0; i < steps; ++i) {
+#ifndef __UCLIBC__
start = std::nextafter(start, direction);
+#else
+ start = ::nextafterf(start, direction);
+#endif
}
return start;
}